+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Issues getting "Forgot Password" email in SF 5.4.4020

Issues getting "Forgot Password" email in SF 5.4.4020

2 posts, 0 answered
  1. Travis
    Travis avatar
    86 posts
    Registered:
    15 Oct 2008
    21 Oct 2014
    Link to this post

    Hello,

    We are using the LoginWidget control, and we are using its feature of providing a link to "forgot your password". When we click on "Forgot your password" we get a slightly different view of the control, with just a textbox to enter the email address we'd like reset assistance with. I can enter my email, which is registered in the system, and hit the "Submit" button, and it says the email is successfully sent, but, nothing ever comes to my inbox. At first I thought this was due to SMTP settings, however, I double checked the settings in Advanced Settings > Notifications > Profiles, and in Advanced Settings > System > SMTP. After making this change, I tested the SMTP details from the Basic Settings > Email Campaigns, and I received the email. Since it was still not working, I built another SMTP provider. Then, in Advanced Settings > Notifications > DefaultProfile, I modified it to point to the new SMTP Provider. Still, when attempting to get a password reset email, I'm not getting anything in my inbox, but Sitefinity is saying everything worked correctly? What do I need to do to tell the "Forgot Password" control to use the correct details for emailing?

     

    I should also mention that the email address I'm sending to, in both the test and that is registered in the system as a user, is the same, so, it should not be a matter of "checking my spam folder" or anything like that.

     

    Any suggestions?

  2. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    02 Dec 2016
    24 Oct 2014
    Link to this post
    Hello Travis,

    In order Reset password functionality to work properly you have to configure the following:

    1. Notifications profiles;
    2. SMTP (Email Settings);
    3. Security settings;

    I have recorded and a short video to demonstrate where the neccessary settings are located. Keep in mind that you have to restart the application in order the changes to have effect. You can achieve this by re-saving the web.config or recycling the application pool.

    http://screencast.com/t/hklPrxbxQVF

    Regards,
    Kaloyan
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered