+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / JavaScriptEmbedControl isn't loading kendo scripts

JavaScriptEmbedControl isn't loading kendo scripts

2 posts, 1 answered
  1. Bryson
    Bryson avatar
    13 posts
    Registered:
    14 Jan 2016
    08 Mar
    Link to this post

    In our default.master page we WERE loading our kendo scripts using the script tag.

    <script src="/Scripts/kendo/kendo.all.min.js"></script>
    <script src="/Scripts/kendo/kendo.aspnetmvc.min.js"></script>

    Then someone got the idea of using the JavaScriptEmbedControl to load them like this:

    <sfpc:JavaScriptEmbedControl id="kendoall" runat="server" scriptembedposition="InPlace" url="~/Scripts/kendo/kendo.all.min.js" />         <sfpc:JavaScriptEmbedControl id="kendoaspnetmvc" runat="server" scriptembedposition="InPlace" url="~/Scripts/kendo/kendo.aspnetmvc.min.js" />

     

    Why are they now not being loaded onto our pages?

     

    As an aside, is there a disadvantage to ALSO be loading jquery here?

    <sfpc:JavaScriptEmbedControl id="jquery" runat="server" scriptembedposition="InPlace" url="~/Scripts/jquery-2.1.4.min.js" />         <sfpc:JavaScriptEmbedControl id="jqueryui" runat="server" scriptembedposition="InPlace" url="~/Scripts/jquery-ui-1.11.4.min.js" />         <sfpc:JavaScriptEmbedControl id="pwstrength" runat="server" scriptembedposition="InPlace" url="~/Scripts/jquery.pwstrength.bootstrap-1.2.9.min.js" />         <sfpc:JavaScriptEmbedControl id="validate" runat="server" scriptembedposition="InPlace" url="~/Scripts/jquery.validate.min.js" />         <sfpc:JavaScriptEmbedControl id="unobtrusive" runat="server" scriptembedposition="InPlace" url="~/Scripts/jquery.validate.unobtrusive.min.js" />

  2. Bryson
    Bryson avatar
    13 posts
    Registered:
    14 Jan 2016
    08 Mar
    Link to this post
    Somehow, apparently, it was removed from the templates we were using. So they put them there and now they're back!
    Answered
2 posts, 1 answered