+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Jquery error on newly created backend pages

Jquery error on newly created backend pages

5 posts, 0 answered
  1. Diogo
    Diogo avatar
    2 posts
    Registered:
    06 Aug 2015
    17 Dec 2015
    Link to this post

    I've created a new backend page, under the "User Management"
    folder. However, as soon as the page is loaded, even before
    I insert any widgets there, I get a javascript error:

    "Uncaught TypeError: jQuery is not a function"

    In the following code:

    <script type="text/javascript">
        if (jQuery(".sfSiteSelectorMenuWrp").length > 0)
            jQuery("body").addClass("sfHasMultiSite");
    </script>

    which is sitefinity native code.

    The reproduction steps are: 
    Administration->BackEnd Pages->User Management - Create Child Page

    Has anyone else had this problem before?

    Best regards,
    Diogo Bastos

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    22 Sep 2016
    22 Dec 2015
    Link to this post
    Hello Diogo,

    On which version you are observing that behaviour? Are you using the default template, custom one or start from scratch? 
    In case of custom template do you have any scripts loaded?

    Testing it on 8.2 works fine. The page is created without any errors using the default template or start from scratch (screenshot).

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Nelson
    Nelson avatar
    14 posts
    Registered:
    29 Dec 2010
    31 Mar
    Link to this post
    We have the exact same problem after an upgrade to 8.2. Did you figure out what caused it?
  4. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    22 Sep 2016
    05 Apr
    Link to this post
    Hello Nelson,

    What is the jQuery version used in your project? Sitefinity 8.2 uses jquery 1.11.2.

    You can check also under: Administration > Settings > Advanced > Pages > Script Manager > Script References > JQuery
    In case there some different version is loaded.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Diogo
    Diogo avatar
    2 posts
    Registered:
    06 Aug 2015
    05 Apr
    Link to this post

    Hello, sadly I did not figure out the problem. After making sure that the Jquery versions matched and that the problem was not in the configurations, I resigned myself to creating a new page template and loading the scripts with script widgets.

    Hope this helps.

    Regards,

    Diogo

5 posts, 0 answered