+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Kendo Nav Menu IE11

Kendo Nav Menu IE11

12 posts, 0 answered
  1. Mike
    Mike avatar
    8 posts
    Registered:
    23 Apr 2009
    03 Dec 2013
    Link to this post
    Is anyone else having a problem with the Kendo Navigation Menu in IE11?  I have a Horizontal Navigation Menu setup to dropdown on hover, but the dropdowns don't work at all in IE11.  Hovering over a menu item does nothing in IE11, but in all other browsers (and earlier versions of IE) the dropdown works correctly.  Has anyone else had this problem?
  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    04 Dec 2013
    Link to this post
    Hello Mike,

    I have answer you already in the support ticket:

    Officially IE11 is not supported and that is the reason that your code does not work as you expect. There is a easy workaround - you just need to add the following meta-tag in the page head:
    <meta http-equiv="X-UA-Compatible" content="IE=10" />

    This should be added under:
    - Pages 
    - <your page> with the navigation widget
    - Title and properties menu
    - add the code above in section 'HTML included in the <head> tag (except title, keywords, description)'

    Regards,
    Svetoslav Manchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Tyler
    Tyler avatar
    9 posts
    Registered:
    10 Jul 2012
    10 Dec 2013 in reply to Svetoslav Manchev
    Link to this post
    I tried adding in this meta tag since I am experiencing the same problem and it doesn't seem to make a difference? Did this work for you Mike?

    Thanks!

    Tyler
  4. Mike
    Mike avatar
    8 posts
    Registered:
    23 Apr 2009
    10 Dec 2013
    Link to this post
    Yes, this actually worked for me.  I put it in the head of my master pages so that it would apply to all pages in the site.
  5. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    12 Dec 2013
    Link to this post
    Hello,

    @Tyler,
    In the next Sitefinity release the RadControls and Kendo UI will be updated. Hopefully the IE11 will be supported.

    Regards,
    Svetoslav Manchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Sunita
    Sunita avatar
    4 posts
    Registered:
    10 Jul 2014
    10 Jul 2014 in reply to Svetoslav Manchev
    Link to this post

    Hi Svetoslav Manchev's,

    I have also same IE problem. I  have  tried your solution but that is not  working.

    Why it is? dont know , can you please suggest any other solution.

     

  7. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    10 Jul 2014
    Link to this post
    Hi Sunita,

    Which version of Sitefinity you are using? You can try to set it to: IE=9.

    Alternatively, you can try the approach proposed below - to add this code in the head tag of Master Page or upgrade your project to the latest Sitefinity version.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  8. Sunita
    Sunita avatar
    4 posts
    Registered:
    10 Jul 2014
    11 Jul 2014 in reply to Svetoslav Manchev
    Link to this post

    Hello Svetoslav Manchev,

    I set it to IE=9 and also tried to set  IE=edge.

    but problem still occurring in IE 9. kendo menu is click-able but not rendering particular pages and its successfully working in all other browsers  except IE.

    Can you please suggest solution?

     

     

     

     

  9. Sunita
    Sunita avatar
    4 posts
    Registered:
    10 Jul 2014
    15 Jul 2014 in reply to Sunita
    Link to this post

    Hi,

    still problem for kendo loader.
    Its only moving continuously on page.

     

  10. kamii47
    kamii47 avatar
    71 posts
    Registered:
    02 Mar 2007
    15 Jul 2014 in reply to Sunita
    Link to this post

    Sunita Which version of Sitefinity you are using?

  11. Sunita
    Sunita avatar
    4 posts
    Registered:
    10 Jul 2014
    15 Jul 2014 in reply to kamii47
    Link to this post

    Hi,

    i am working  with vs2012 and kendo framework(2013.3.1119.340).

    Application work properly in All browser except IE 9 and IE 10 .

    Actually problem is when we edit(Inline editing in kendo grid ) in kendo grid  and click on save button , then loader continuously moving and not appearing the kendo grid(means not visible grid). But manually refresh the page that time record is updated and grid visible.

    Its kendo grid problem in IE9?

    Can you please suggest solution.

     

  12. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    15 Jul 2014
    Link to this post
    Hello Sunita,

    This looks like a caching issue and I would recommend you to try disable cache (add an attribute cache:false).

    Let us know if this helps.

    Regards,
    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
12 posts, 0 answered