+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Local SiteSync Not Connecting

Local SiteSync Not Connecting

6 posts, 0 answered
  1. Cody
    Cody avatar
    4 posts
    Registered:
    17 Mar 2014
    20 Mar 2014
    Link to this post

    So, we're evaluating Sitefinity and currently building everything locally. I've got two projects, completely following the SiteSync Prerequisites & Restrictions documentation. They are both running under the same instance of Sitefinity Project Manager on localhost. The connection URL I'm using in the sync settings is: http://localhost:3801/Rally_Production/

    All I'm getting as an error is, "Server http://localhost:3801/Rally_Production/ is not accessible." Am I missing something?

  2. Cody
    Cody avatar
    4 posts
    Registered:
    17 Mar 2014
    20 Mar 2014
    Link to this post

    Found in this video that the receiving server must be on IIS, not the default Sitefinity Project Manager. Would be useful to have in the standard written documentation.

  3. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    25 Mar 2014
    Link to this post
    Hi,

    Glad to hear that the problem has been resolved. You are correct all projects should be deployed on IIS. Furthermore, you need to make sure that:

    1. If you think of your site stages (development, staging, production, etc.) as a network of connected servers, each of them must have a unique key in that network. The site key participates in the incremental GUID generation algorithm ensuring that any GUID generated with one site key is different from any GUID generated with any other key. Thus, items created on your development server have IDs that are guaranteed to be different from the IDs of the items created in parallel on your staging server, which guarantees that no ID clashes during synchronization. If you synchronize from Staging to Production (A to B) please note that the key set in A should be smaller than the number set on B. You need to set these keys manually before the synchronization.
    2. You entered administrators credentials in the first site and you are not logged in the second site during synchronization (or during testing the connection)
    3. The synchronization is one way, you could synch from Development to Staging, but once you have synchronized from Development to Staging, you should not synch from Staging to Development

    4. In IIS configurations anonymous authentication should be enabled and all other authentications should be disabled. Please review the screenshot.

    We will send a request to our documentation team to add this important note. Thank you for reporting this problem your Telerik points have been updated.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  4. Meggita
    Meggita avatar
    2 posts
    Registered:
    13 May 2014
    25 Jun 2014 in reply to Stefani Tacheva
    Link to this post

    Hi Stefani,

    I have the same issue here. I have an enterprise license, my staging is running on iis, I created a separated admin account for staging and staging is not logged in. And the anonymous authentication is enabled... I ran out the clue.

    When I create my staging, I actually restored db from my local sitefinity db, I guess it will have the same sitefinity instance ID, Is this the same problem as you mentioned in your point 1? Otherwise, my staging is running on aws, could this be a potential problem, too? 

    Thanks.

  5. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    01 Jul 2014
    Link to this post
    Hello,

    Regarding the information in point 1 you need to make sure that the site key in your first instance (source) is smaller then the site key in your second instance (destination).

    You can test whether the service is visible from the first note to the other. Under the first note request:

    http://localhost/Sitefinity/Services/SiteSync/SiteSyncService.svc/ConfirmConnection/

    Change localhost with the host that you are using. If you are receiving 404 error then the server is not accessible (visible). You need to start seeing HTTP Error 401.0 - Unauthorized instead of 404 error.

    You need to make sure that you have these configurations applied:

    http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/install-sitefinity/configuring-the-iis-to-host-sitefinity-projects

    If you have set NetworkService as your application pool identity, make sure to check that the anonymous user identity is the same as the application pool identity. Then for the website folder, verify that NetworkService has read / write permissions.

    If the problem still persist you could test it locally or on another machine.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  6. Meggita
    Meggita avatar
    2 posts
    Registered:
    13 May 2014
    02 Jul 2014 in reply to Stefani Tacheva
    Link to this post

    Hi Stefani,

    Thanks for the reply. It turned out the SiteSync module wasn't installed on my staging in the first place. Once I installed the module, "Allow content from other sites to be published to this site", then set the Site Key larger than 1, everything is working now.

    Thank you.

6 posts, 0 answered