+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / No scrollbars when editting a page

No scrollbars when editting a page

5 posts, 1 answered
  1. Donna Stewart
    Donna Stewart avatar
    8 posts
    Registered:
    28 Apr 2009
    31 Oct 2012
    Link to this post
    In Sitefinity 5.1, when you click to open a page to edit it, I have no scrollbars.  I can not get to some of my content blocks.  This is true in IE 9 and Firefox.  I upgraded to Sitefinity 5.2, but I still have the issue.  I have searched to see if anyone else has posted with this problem, but i didn't find anything for 5.1 or 5.2.  It is difficult to search now since we can't search on specific forums and the search returns answers from all different areas.  I am new to Sitefinity, so I may be doing something wrong or maybe I don't know of some sort of setting.  I did look at Pages under the Administration -> Settings -> Advanced, but I didn't see anything that I thought would help.  I am pretty much stuck until I can get scrollbars to edit my page.  Please - any and all help is  much appreciated!

    Thanks,
    Donna
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    01 Nov 2012 in reply to Donna Stewart
    Link to this post
    Well good news is that it's not sitefinity :) ...well technically

    If you fire up a new blank SF instance it'll be there and working fine

    That means the problem is likely an overflow:hidden rule in your css somewhere; I mean that's usually where I start.  Open up firebug and go investigating.

    Steve
  3. Donna Stewart
    Donna Stewart avatar
    8 posts
    Registered:
    28 Apr 2009
    01 Nov 2012 in reply to Steve
    Link to this post
    Hi Steve,

    Thank you so much for your help.  I did in fact have an overflow:hidden in the css file for my template theme.   I have removed it, but I still have the issue.  I think there is a caching problem.  I have tried clearing the cache, reloading with Shift + Reload, setting the theme to basic, publishing and resetting it to my theme.  I still have the issue.  I had a similar caching problem the other day when I changed the background color in my theme css.  The change was visible when I viewed the site (browsed to it), but in the page editor in Sitefinity, it kept the old color.  I honestly can't remember what exactly I did for it to finally change in Sitefinity, but it did.  Is this a common issue, or again something silly I have done?

    Thank you again,
    Donna

  4. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    02 Nov 2012 in reply to Donna Stewart
    Link to this post
    Hey Donna,

    Development & caching are always biting each other a bit. This is caused by the fact that IIS considers your .css as static content in a virtual (non-existing) folder.

    If you go into web.config and comment out this:
        <staticContent>
          <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="31.00:00:00" />
        </staticContent>
    and recycle the application after that, things will probably go smoother during development.

    If you rather not change the web.config and clearing your browser cache still doesn't work you can try the following 4 hacks:

    1. Publish the page, clear browser cache, edit the page instead of merely open and going back.
    2. Rename the .css file, refresh the page (can't find .css) rename the .css file back, refresh the page.
    3. Open web.config add a space, close it, refresh your page.
    4. Recycle app-pool.

    Jochem.
  5. Donna Stewart
    Donna Stewart avatar
    8 posts
    Registered:
    28 Apr 2009
    06 Nov 2012
    Link to this post
    Hi, just to follow up and let whomever might be interested know what happened, I tried everything mentioned to no avail.  So, I created a brand new project and moved my code over to it.  Still no scrollbars.  I examined my css file (which isn't very large at this point) and took out a couple of lines I thought could possibly be causing the issue.  One of the lines I removed was position:absolute in a class on one of my main divs.  This was the culprit.  I removed it, got scrollbars, put it back, no scrollbars.   I was using it to  center the div.  I changed it to use margin: 0 auto; and that worked!  Thank you both for your help!

    Donna
    Answered
5 posts, 1 answered