+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Nothing happens when I click the settings button for Responsive

Nothing happens when I click the settings button for Responsive

4 posts, 0 answered
  1. Belinda
    Belinda avatar
    12 posts
    Registered:
    26 Sep 2013
    11 Mar 2015
    Link to this post

    I am following these directions for responsive:

    In page editing mode, click Layout button in the upper-right corner of the page.Under Responsive Layout, click Settings.Choose one of the following: As set in the base template. The responsive design takes the setting from the template that the current template is based on.

    But when I click the Button "Settings" - nothing happens.  Please advise.  Thanks!

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    28 Sep 2016
    16 Mar 2015
    Link to this post
    Hello Belinda,

    Can you please let me know the exact Sitefinity version you are using? I have tested this on my side on a Sitefinity project version 7.3 and I was not able to reproduce it.

    I am sending attached a short video demonstrating the steps I took on my side on a test Sitefinity 7.3 project and the results.

    Is it also an option for you to record a video demonstrating the exact steps you take and the behavior on your side? In addition to this, please inspect the browser's console in order to check if there are any error messages logged there when you press the Settings button.

    In addition to this, can you please delete the files under the ~/App_Data/Sitefinity/Logs folder (or copy the files to another location for backup) and then try to reproduce the issue. After that please check if there are any log files under the Logs folder and send the files to inspect them. There might be some error messages logged in this files which may provide more details about the issue.

    Moreover, please create a brand new page in your Sitefinity project with no template assigned to it and test the behavior again and let me know about the results?  

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Belinda
    Belinda avatar
    12 posts
    Registered:
    26 Sep 2013
    17 Mar 2015 in reply to Sabrie Nedzhip
    Link to this post

    HI-- We are using Sitefinity 7.3.  If I don't have a template assigned to the page, the 'settings' button works.  I am getting an error message in the console that says "'Attr.nodeValue' is deprecated. Please use 'value' instead." but I don't know if that is related.  

  4. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    28 Sep 2016
    20 Mar 2015
    Link to this post
    Hi Belinda,

    Since the issue does not reproduce when you create a new page with no template, it seems that the issue is caused by any custom logic you have on your page template.

    In order to try to isolate the problem you can try to remove one by one the widgets you have on your page template in order to check if the issue is caused by a widget. Can you please also try to comment out the custom scripts in you page template, if any and test again. This way you can see if the issue is caused due to conflicts between scripts you are loading on your page template or on your page. 

    This error might be caused for example due to a conflict between the javascript you are loading on your page or page template and the version of the jQuery libraries Sitefinity uses. Please note that by default Sitefinity uses the built-in jQuery library (version 1.8.3) and we highly recommend that you use the same version in your project. 

    To do this, you can use the ResourceLinks control as shown below which will ensure that the built-in jQuery library is loaded on your page or page template:

    <%@ Register Assembly="Telerik.Sitefinity" Namespace="Telerik.Sitefinity.Web.UI" TagPrefix="sf" %>
               
    <sf:ResourceLinks ID="resourcesLinks" runat="server">
        <sf:ResourceFile JavaScript Library="JQuery" />
    </sf:ResourceLinks>

    Please refer to the following article for more details on this.

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
4 posts, 0 answered