1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Page and template migration issue 3.7 to 4.1

Page and template migration issue 3.7 to 4.1

5 posts, 0 answered
  1. Nick
    Nick avatar
    10 posts
    Registered:
    09 Jun 2008
    11 May 2011
    Link to this post

    Pages and templates come in but are not associated with the templates.
    In edit mode they are empty but can be viewed in live mode. In live mode the content is there with no template.

    On attempting to assign a template (.master) to some of the pages, we get this error

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Sitefinity.Modules.GenericContent.ContentManager.IsContentBlockHtmlObsolete(String serverSideControlID, Guid pageId, ContentLifecycleStatus clcStatus, CultureInfo culture, String pageProviderName) +209
       Telerik.Sitefinity.Modules.GenericContent.ContentManager.IsContentBlockHtmlObsolete(String serverSideControlID, Guid pageId, ContentLifecycleStatus clcStatus, CultureInfo culture) +71
       Telerik.Sitefinity.Modules.GenericContent.ContentManager.IsContentBlockHtmlObsolete(String serverSideControlID, Guid pageId, ContentLifecycleStatus clcStatus) +121
       Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlock.get_IsOutDated() +277
       Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlock.get_CustomMessages() +193
       Telerik.Sitefinity.Web.UI.ZoneEditor.CustomizeControlDockTitlebar(Control control, RadDock dock) +169
       Telerik.Sitefinity.Web.UI.ZoneEditor.AddControlToContainer(ControlData controlData, Control container, Boolean addLast) +419
       Telerik.Sitefinity.Web.UI.ZoneEditor.AddControlDocksToZone(String placeHolderId, Control zone) +161
       Telerik.Sitefinity.Web.UI.ZoneEditor.ProcessPlaceholder(Control placeholder) +159
       Telerik.Sitefinity.Web.UI.ZoneEditor.ProcessPlaceholders() +117
       Telerik.Sitefinity.Web.UI.ZoneEditor.CreateChildControls() +117
       System.Web.UI.Control.EnsureChildControls() +102
       System.Web.UI.Control.PreRenderRecursiveInternal() +42
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Control.PreRenderRecursiveInternal() +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2496

    There is a link associated with this particular error on the forums
    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/general-discussions/database-missing-error-when-upgrading-to-4-1.aspx

    but this did not update any rows. We ran it over the migrated 4.1 database. Should we have run it over the 3.7 one first? Or, perhaps is the ContentBlock or ContentBlockBase different?

    Anyway, the major problem we have at the moment is around 1900 pages without associated templates. Happy to run diagnostic SQL queries and return results if that helps.
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    13 May 2011
    Link to this post
    Hi Nick,

    This error occurs because of the new shared content block behaviour. It has been resolved in 4.1 SP1 that is due to be released today (Friday).

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Nick
    Nick avatar
    10 posts
    Registered:
    09 Jun 2008
    17 May 2011
    Link to this post
    Hi Lubomir.
    Thanks for the update, this does fix the content block error. However, the service pack (4.1 SP1) appears to cause another error around the AJAX controls, when re-running the migration tool. It appears the MS AJAX framework fails to load.
    Had a look around the forums and this http://www.telerik.com/community/forums/aspnet/ajax/asp-net-ajax-client-side-framework-failed-to-load.aspx seemed related, but none of the fixes in there seemed to work.

    Regards,
    Nick

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    23 May 2011
    Link to this post
    Hello Nick,

    It looks like there is an issue with loading the AJAX Framework. This does not seem to be related to the migration tool. Is there are difference if you run the projects through VS. Have you tried to use another machine or virtual server?
    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Nick
    Nick avatar
    10 posts
    Registered:
    09 Jun 2008
    30 May 2011
    Link to this post
    Looks like the easiest thing for us will be to revert to the AjaxControlToolKit.dll  3.0.20820.16598 for our custom controls. Thanks for the updates.
5 posts, 0 answered