+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Page redirects does not keep the query string part of the URL

Page redirects does not keep the query string part of the URL

8 posts, 0 answered
  1. Michael
    Michael avatar
    41 posts
    Registered:
    07 Nov 2013
    10 Jan 2014
    Link to this post
    Hi all,

    It seems that when a page has several URLs, and a redirect occurs (to the same page, just with the default URL), the query string portion is discarded.

    Just wondering if anybody else encountered this issue. Or possibly my page settings is not set correctly.

    This is happening on a page that I migrated from 3.7 to 6.2.

    Thanks,
    Michael
  2. Michael
    Michael avatar
    41 posts
    Registered:
    07 Nov 2013
    10 Jan 2014
    Link to this post
    I should add that this is happening with URLs that contain spaces. It seems that in 3.7, spaces were OK. In 6.2, spaces in URLs do not appear to be acceptable.
  3. Greg
    Greg avatar
    16 posts
    Registered:
    11 May 2011
    05 Jun 2014
    Link to this post
    This is happening to me as well.  It is pretty annoying.  Is there any way around it? I don't see anything in settings, and haven't found anything online.
  4. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    09 Jun 2014
    Link to this post
    Hello Greg,

    Could you please provide more information about the scenario you have?

    Please find a video demonstration of what I have tested on version 6.2. The query string is kept after additional url redirect.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Greg
    Greg avatar
    16 posts
    Registered:
    11 May 2011
    09 Jun 2014 in reply to Svetoslav Manchev
    Link to this post
    I'm running 6.1, is this fixed in 6.2?  The exact scenario demonstrated in the video does not work on my system.
  6. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    09 Jun 2014
    Link to this post
    Hi Greg,

    Yes, this issue is fixed in 6.2. So in order to have it solved, you can upgrade your project to the latest Sitefinity version following that article.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Greg
    Greg avatar
    16 posts
    Registered:
    11 May 2011
    03 Oct 2014 in reply to Svetoslav Manchev
    Link to this post

    I just upgraded our system to 7.1 (finally!) but this has not been fixed.  querystring parameters still get dropped from the URL in a redirect scenario.

  8. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    07 Dec 2016
    08 Oct 2014
    Link to this post
    Hello Greg,

    I just have tested the same scenario from the video provide before and it works as expected on version 7.1.

    What I would recommend you is to open a support ticket in order to inspect the issue more detailed on your site.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
8 posts, 0 answered