+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Password Reset not working on Login or User Screen

Password Reset not working on Login or User Screen

24 posts, 1 answered
  1. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    05 Jan 2012
    Link to this post
    I'm using Sitefinity 4.4 and trying to reset a user's password after she told me the 'Forgot Your password?' link wasn't working.

    I've verified that when clicking the link on the login page it does nothing in any browser. I figured as a workaround I could go to the users screen and click on the 'Reset password' button. After clicking the button a new password is no longer shown.

    Is this something that other people are experiencing or have I done something to cause this behavior (I don't think I have)?
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    06 Jan 2012
    Link to this post
    Hi Mark,

    First of all you need to set properly your SMTP settings in Administration -> Settings -> Advanced -> System -> SMTP Settings. Do not forget to set a valid sender email address. Also for your membership provider - I suppose it is the "Default" one, you need to set the enablePasswordReset property to "true". Go to Administration -> Settings -> Advanced -> Security -> Membership Providers -> Default -> Parameters and there set a valid

    recoveryMailAddress
    enablePasswordReset

    Also make sure that recoveryMailBody contains the following special tag:

    <%\s*Password\s*%>

    Regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. Scott
    Scott avatar
    12 posts
    Registered:
    26 Oct 2011
    17 Jan 2012
    Link to this post
    I'm having the same problem - in 4.2. Not working like it did in earlier versions.

    What are all these steps we have to take all of sudden.
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    18 Jan 2012
    Link to this post
    Hello Scott,

    We made some changes to the way the reset password functionality works. Is my previous reply not working for you?

    Regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    19 Jan 2012
    Link to this post
    This reply is not working for me. I put in a support ticket request.

    Also, does this mean that the user will get their password sent to them via email every time they change their password or only when they need a new password sent to them because they forgot?
  6. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    21 Jan 2012
    Link to this post
    Hello Amanda,

    I replied to your ticket. The user will get an email every time the password is being changed. However you need to include the special tag - <%\s*Password\s*%> - that will be replaced with the actual password in the email body.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Kristian
    Kristian avatar
    214 posts
    Registered:
    03 Jun 2010
    23 Jan 2012
    Link to this post
    I have all these settings set properly, the resets work properly, but do we not see the new password in the backend interface anymore?
  8. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    25 Jan 2012
    Link to this post
    Hello Kristian,

    This is strange. You should see the new password in a yellow box like the attached image.


    All the best,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. RebootLN
    RebootLN avatar
    25 posts
    Registered:
    21 Aug 2010
    13 Mar 2012
    Link to this post
    was there a resolution to this.

    I (as admin) also do not see the new password - there is no yellow box after you click "reset password" in edit user screen.

    In addition - the sitefinity log in screen forgot password doesn't do anything. 
    i changed the enablePasswordReset to True

  10. RebootLN
    RebootLN avatar
    25 posts
    Registered:
    21 Aug 2010
    13 Mar 2012
    Link to this post
    was there a resolution to this.

    I (as admin) also do not see the new password - there is no yellow box after you click "reset password" in edit user screen.

    In addition - the sitefinity log in screen forgot password doesn't do anything. 
    i changed the enablePasswordReset to True

  11. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    06 Dec 2016
    14 Mar 2012
    Link to this post
    Hello,

    Please excuse us for the inconvenience caused. Actually we have introduced some changes in this functionality since the Sitefinity 4.4 release for security improvements. If you want to enable the password reset functionality you'll need to go to Advanced settings and edit the Default MembershipProvider parameter enablePasswordReset, which is set to flase by default. please set it to true, and also configure defaultSenderAddress to a valid email address which Sitefinity will use when sending the password reset email. Aside from that, you'll need to perform the regular SMTP settings so the application can actually send emails. Once you've got everything configured you might need to recycle your application pool, to make sure the new configuration is read, an you should have the new password displayed in the User profile screen just like it used to in previous versions. Please do not hesitate to let us know if you need some additional information on the issue, or you have any other questions. We'll be glad to help you further.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. RebootLN
    RebootLN avatar
    25 posts
    Registered:
    21 Aug 2010
    15 Mar 2012
    Link to this post
    as per my post above - i had already changed the setting to true and email is working properly.

    Please advise

  13. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    06 Dec 2016
    20 Mar 2012
    Link to this post
    Hi,

    The DefaultSenderEmailAddress parameter belongs to the System SMTP settings, and is configured under Administration -> Settings -> Advanced -> System -> SMTP settings, please make sure it is filled in with a valid email address.
    Under parameters for the Default MembershipProvider, please make sure you've set the recoveryMailAddress to a valid email address; enablePasswordReset and enablePasswordRetrieval to true, and try restarting the application to make sure the new provider keys are loaded. If any issues persist, please do not hesitate to get back to us.

    Kind regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  14. Sebastian
    Sebastian avatar
    21 posts
    Registered:
    06 Sep 2011
    02 May 2012
    Link to this post
    It does not work for me as well.  I followed your instructions with setting values inside the config files.  
    It does send am email when I change the password from Administration-> Users page.  It does not do it from my website.

    Side note: I can send emails from my website without a problem.

    What do you think Boyan?  I am using SF50 with latest pack.
  15. Chanan Zass
    Chanan Zass avatar
    123 posts
    Registered:
    21 Aug 2012
    06 May 2012
    Link to this post
    I can confirm that backend password reset works with Version 5.0 SP1.
    There are limitations of course when comparing it to the standard ASP.NET password recovery, where localized email subject and body are easily implemented. Here you're stuck with English.

    Is there a template one can work on to implement backend password reset?
  16. Sebastian
    Sebastian avatar
    21 posts
    Registered:
    06 Sep 2011
    07 May 2012
    Link to this post
    I got it to work. 

    There are two places where DefaultSenderEmailAddress field has have a valid email: SMTP and Notifications.

    I had the SMTP email correct, I did not have default email at Administration -> Advanced -> Notifications -> Profiles -> Default.
  17. Bob Howard
    Bob Howard avatar
    22 posts
    Registered:
    06 Jan 2008
    07 Aug 2012
    Link to this post
    I spent a good part of the day trying to get this to work.  I followed the instruction according to Lubomir and Mark.  I don't see an option for reseting the password.  Can someone help?  I am running Sitefinity Version 5.1.3210.0.
  18. Sebastian
    Sebastian avatar
    21 posts
    Registered:
    06 Sep 2011
    22 Aug 2012
    Link to this post
    Did you get it to work Bob?
  19. Sabrlin
    Sabrlin avatar
    1 posts
    Registered:
    22 Oct 2012
    22 Oct 2012
    Link to this post
    Maybe you can make use of password reset tool like Smartkey
  20. Larry Miclette
    Larry Miclette avatar
    10 posts
    Registered:
    19 Nov 2009
    28 Jan 2014
    Link to this post
    Has anyone gotten this to work? I have valid email addresses in both notifications and SMTP settings, but the change password button in Administration -> Users does not send an email to the user. Can't get this to work.
  21. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    28 Jan 2014
    Link to this post
    I'm having no luck with this on 6.3 using Claims authentication
  22. Chanan Zass
    Chanan Zass avatar
    123 posts
    Registered:
    21 Aug 2012
    28 Jan 2014
    Link to this post

    As far as I know the backend user administration is not designed to sent out new passwords to user.

    The old discussion above regarded the front-end login widget.

     

  23. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    28 Jan 2014
    Link to this post
    Until I converted to claims, it has been working on the backend login screen. You simply clicked the reset my password link, typed in your email address and a new password was sent to you.
  24. Chanan Zass
    Chanan Zass avatar
    123 posts
    Registered:
    21 Aug 2012
    28 Jan 2014
    Link to this post

    Thought you were talking about the Administration > Users grid. Sorry.

    Seems to me you need to set parameters of the new membership provider. What you used before is probably "OpenAccessMembership37Provider."

    What you use now is the Default provider.

    Administration > Settings > Advanced > Security > Membership Providers > Default > Parameters

    Hope this helps.

24 posts, 1 answered