+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Persistent "File or Directory not found" after live migration.

Persistent "File or Directory not found" after live migration.

24 posts, 0 answered
  1. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    Hi,

    I have been through the support process which is still ongoing however I thought I'd open this up to the community as I'm getting some pressure to get this working.

    Our instance of Sitefinity has been through our QA process and I was in the process of migrating it to Live. The site is all setup and 95% of it works. However when trying to save anything, settings, pages, users etc. I get presented with a "404 - Fire or Directory not found". I have been through every page of documentation and Telerik themselves have looked over the server and Sitefinity instance. Still with no joy. It clearly presents itself as a permissions issue however I have created test pages outside of Sitefinity that validate the correct permission are configured. I have setup all handlers, full trust, etc etc still with no joy.

    Had anyone experiences this problem before? I'm getting desperate.

    Thanks
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Dear Paul

    What Version
    What IIS? Local, Production
    What SQL Sever? Local Production
    What kind of authorisations? Local Production
    What kind of .net 4, 4 Integrated ? Local Production
    Did you check App_data/sitefiniy/logs/  any clues there?
    Does Fiddler show anything when you try to do something on the production server?

    I know not really helping but brainstroming sometimes helps for new ideas.

    I guess since you have it working local I would simply be looking for where the server differs.


  3. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    Any help is appreciated...

    - Latest Sitefinity version
    - IIS 7 local, QA and Live
    - SQL 2008 R2 local, QA and Live
    - Auth is the same in Sitefinity, we have a specific domain user for AppPool this is replicated in all environment. However we have tried AppPool identity and network service.
    - AppPool are all identical as in integrated
    - No logs get logged at all, nor in the system event log

    A trace only shows this....
    01.Request URL:http://[URL Removed]/Sitefinity/Services/Configuration/ConfigSectionItems.svc/general/00000000-0000-0000-0000-000000000000/
    02.Request Method:PUT
    03.Status Code:404 Not Found
    04.Request Headersview source
    05.Accept:*/*
    06.Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.3
    07.Accept-Encoding:gzip,deflate,sdch
    08.Accept-Language:en-GB,en-US;q=0.8,en;q=0.6
    09.Connection:keep-alive
    10.Content-Length:154
    11.Content-Type:application/json
    12.Cookie:ExpFrontEndPages=%5B%22f69962de-c3aa-478e-b33f-68a6a8f382c6%22%5D; __utma=130624285.1863978846.1335455807.1346227871.1346324353.41; __utmz=130624285.1338994375.22.2.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=(not%20provided); ASP.NET_SessionId=nfozmtxte5w3w2sfzue5btop; .ASPXAUTH=64D63857C2FF64A6622A486EB1920DB6471B73E881966A3638DD88CA674CD42A6EC6513FA786AA164BED31E4BF0CAC543888A6A7DC3A4CA4A735916AA6D72960EB52F271FC78CA1CBAFB15B3E6ECF85EE03BB3D9AB921BFF8989EDAE9C96E5BA048040970779A22A242EFADB86944C21BE27A818D86651C63506924A585759623FA44EDD; FedAuth=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; FedAuth1=UFRtZERXNVRUNVBSZUc5aTNJM0llcDVEcldnU28xbU5haUhlTFdrblljRjF4OTZaSGkxRTRyZXRnWXhzb281aThBSzdjdyt4MjJLWERhaWo5K1pNS0NhUGwwSVd3dStLTFpNSDNOZWpOc05JMzd2ZnFuMWl2VVlCZEFKMGdla2Fpb0NNWDRqaHQzNk8zT3pKakxZQStLT3ZCbzBJR2xHbmx5aEliOWc5V2wxak85UWY0QjIrSVowWWRId3dnZU1TdUdIQURBS0IwL2pKU3JxMmU1TXV0Y0NCR1VkdDVjRENaMmh6TTl4ZmFkSmk5bkRxRnQxQmJkTUgwaW10b3A5aDVucE1Fa3cxYVhHdVFSdU9nL1hOaUozNnl0NTFVNnJsWG1zWGZGVmRDaWxab2crRGdBUEF5WXVzV2xlNzl4V3NienBYVXM2cGk0MTFYZXhYQWlIV2ZGbDRVd1c5a21XbXhCVmUxL3ppWGM2UURjSDZJUkI3TVA2TUkzZTE0K1EwV0R3S2RoUHo0ZHpoVC8vWEcvS0ltdHVRVDhjdHNscisyeDR4UzBsLzZXcUM3Rnk2SkEvb0ZmUGJIS25JdzFqaW80ZzIxZmpTOTlMem9PSUkxRDNvWDBYTnN1eWNZcnhRZ1FBQUE9PTwvQ29va2llPjwvU2VjdXJpdHlDb250ZXh0VG9rZW4+; SF-TokenId=5170aa79-05ec-4b78-9c13-e678b79a327f
    13.Host:[URL Removed]
    14.Origin:http://[URL Removed]
    15.Referer:http://[URL Removed]/Sitefinity/Administration/Settings
    16.User-Agent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.83 Safari/537.1
    17.X-Requested-With:XMLHttpRequest
    18.Request Payload
    19.{"Item":{"CurrentTimeZoneId":"GMT Standard Time","ProjectName":"Sitefinity","SupportsDaylightSavingTime":"true","LastModified":"\/Date(1346418320224)\/"}}
    20.Response Headersview source
    21.Connection:Keep-Alive
    22.Content-Length:1245
    23.Content-Type:text/html
    24.Date:Fri, 31 Aug 2012 13:05:19 GMT
    25.Proxy-Connection:Keep-Alive
    26.Via:1.1 CC-GW1
    27.X-Powered-By:ASP.NET

  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Dear Paul

    Did you compare all the .config files in QA and Live?
    Any luck with Fiddler?

    Markus
  5. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    Site is identical bar the connection string in DataConfig.config.
    I have used fiddler as it gives the same as above really reporting that when making a call to

    http://url/Sitefinity/Services/Configuration/ConfigSectionItems.svc/general/00000000-0000-0000-0000-000000000000/

    Fiddler reports "The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable"

    It all points to permissions however I can't think what else could cause it as I have configured everything that should be configured. :-S

  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Paul 

    Sorry for my guess work I am not a programmer but still eager to help. And I know that if it works on one server it should on the other as well.

    Can you login in QA and then try to accsss

    http://www.yoururl.com/sitefinity/Services/configuration/configsectionItems.svc

    Then login into Live and try to access

    http://www.yoururl.com/sitefinity/Services/configuration/configsectionItems.svc

    Do both work? Do you have extra folders on the live server you do not have on QA. Like /images/ for example?
    Markus
  7. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    can't access those methods directly....as below. This is the same in all 3 environments.

    Error Description: 'HTTP Method not allowed'

    This may be because an invalid URI or HTTP method was specified. Please see the service help page for constructing valid requests to the service.

  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Paul 
    Edit your post here is an URL in it. And from your previous post I assume you dont want that.

    When I am logged in in one of my production sites I can access for example http://www.myurl.com/sitefinity/Services/configuration/LocalizationCultures.svc/

    As you can see I am a try and error guy. You are logged in as Admin when you try right.

    Strange that it does not work in QA and Live as well.

    Markus
  9. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    Yeah, it's not that it's top secret or anything it just doesn't work outside our network. :-)
  10. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Have you cross check the folders. Are QA and Live identical folder wise.

    This is my last (sorry) shot in trying to help (waste your time) 

    http://www.sitefinity.com/devnet/forums/sitefinity/developing-with-sitefinity/web-deploy-for-sitefinity-5-0.aspx 

    Other then this I have no clue  - sorry. Well if Support does not know how should I.

    Maybe Steve, Jochem or Tim will kick in. They know what they are doing :-)

    Sorry have a nice weekend.

    Markus




  11. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    All help is much appreciated :-)
    We don't use web deploy but those files aren't in our project.

    Everything is identical as the Live site is a cut and paste of the QA site with the connection string changed.
  12. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2012
    Link to this post
    Paul

    Maybe we are barking up the wrong tree. SQL Server problem. 

    How about rights on the database. Read yes, write No?

    Markus


  13. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    31 Aug 2012
    Link to this post
    We're using SQL Authentication. SQL User is a dbo on the sitefinity database.
    I'm not aware on any other SQL permissions needed?
  14. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    03 Sep 2012
    Link to this post
    @Markus,
    Sorry AFK weekend, and mostly I'm just as much in the dark on these quirks as the next guy :)

    @Paul,
    Have you checked whether the web.config files are identical? If so, then most likely the servers are the mismatch because usually the 'HTTP method not allowed' gets flashed when .svc isn't properly mapped to aspnet_isapi.dll.

    You can manually try and repair the mapping by using ServiceModelReg.exe -r which should fix the WCF bindings (or use the -i to install). 

    If that still doesn't solve the issue, try to re-register ASP.NET 4 on the server using aspnet_regiis -i which will try and reconfigure ASP.NET 4 on the server.

    Good luck!

    Jochem,
  15. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    03 Sep 2012
    Link to this post
    Hi,

    I think the HTTP method not allowed is simple because I tried to call the method directly. So it's a little misleading. I believe the WCF handlers are setup correctly as WCF calls are being made. For example, when paging the users page I can see .svc call being successfully made.

    This is production server so I'm reluctant to repair .NET as it had been working flawlessly for the last 18 months.

    I turned on logging for failed requests and we appear to be getting something to do with URL scan though I'm not sure if that isn't just a red herring. As the underlying error seems to a "The system cannot find the specified file"
  16. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    03 Sep 2012
    Link to this post
    @Paul,

    I can understand you being reluctant to play with a production environment.

    Firstly, when I call a service url at a local or production enviroment, I either get a 401 (not authorized) or results (when recognized as admin) as in the screenshot.

    So if the 404's are not happening because of your .svc's not registered properly, it leads to believe either still some handlers aren't registered properly or url-rewriting not working properly. Where some settings are correctly applied but on a machine level on the dev environment, while they need to be set on a web.config level on the production environment.


    Jochem
  17. Paul Smith
    Paul Smith avatar
    14 posts
    Registered:
    06 Mar 2006
    03 Sep 2012
    Link to this post
    Hi,

    Thanks for the help.....

    If I run the same url as your screenshot I get the same results as you. That service all requires no input. If you try another call like the one that are failing for me...e.g.

    ...Sitefinity/Services/Configuration/ConfigSectionItems.svc/general/00000000-0000-0000-0000-000000000000/

    Try running that, I think you should get HTTP method not allowed.

    I have incidentally run the commands your recommends. Both ServiceModelReg and aspnet_regiis. Neither made a difference.


  18. Impact
    Impact avatar
    1 posts
    Registered:
    01 Sep 2010
    04 Oct 2012
    Link to this post
    Hello Paul, just encountered same issue. 

    Check your ISAPI filters on production server. You most likely are using UrlScan. Remove this filter and it should start working. 

    Hope it helps. Cheers.
  19. Nick
    Nick avatar
    113 posts
    Registered:
    21 Oct 2008
    16 Sep 2013
    Link to this post
    Hi Impact,

    I had same problem with sitefinity version 6.1.4000, your fix worked for me. Thanks
    Server: Microsoft 2008, IIS 7.0
  20. Bishoy
    Bishoy avatar
    27 posts
    Registered:
    15 Aug 2013
    27 Sep 2013
    Link to this post
    For me It was the WCF/Http Activation mode, just go to server roles and features and make sure its installed 
  21. Solomon Shaffer
    Solomon Shaffer avatar
    6 posts
    Registered:
    30 Jan 2014
    06 Aug 2014
    Link to this post

    HTTP Activation was it for me as well.

  22. Tipping
    Tipping avatar
    1 posts
    Registered:
    14 Oct 2014
    15 Oct 2015
    Link to this post

    On windows 10

    .Net Framework 4.6 Advance Services > WCF Service > HTTP Activation solved the issue of "404 file or directory not found" alert issue for Sitefinity backend.

  23. Aaron
    Aaron avatar
    3 posts
    Registered:
    30 Sep 2014
    24 Oct 2015
    Link to this post

    Yes, thank you guys. I was having the same issue on Windows Server 2012. Searched high and low and came across this post. HTTP Activation was it for me too.

    Aaron

     

  24. Aaron
    Aaron avatar
    3 posts
    Registered:
    30 Sep 2014
    24 Oct 2015
    Link to this post

    I think the biggest problem is: under the IIS configuration instruction:

    http://docs.sitefinity.com/configure-the-iis-to-host-sitefinity-projects

    Turning WCF Service > HTTP Activation on is not listed under Windows Server 2012. 

     

24 posts, 0 answered