+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Problem Migration from 3.7 (not SP4) to 6.0

Problem Migration from 3.7 (not SP4) to 6.0

3 posts, 0 answered
  1. Michael
    Michael avatar
    2 posts
    Registered:
    10 Jul 2013
    10 Jul 2013
    Link to this post
    I am trying to get a clients site migrated from 3.7.2096.2 to 6.0.4210.0 and keep getting "Connection to 3.7 project has failed." messages at the point of trying to Test Connection. I have:

    * Installed 6.0.4210.0 trial (do not have license purchased yet)
    * Created new project in Project Manager
    * Performed manual setup steps from http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/migrating-your-sitefinity-3-7-project
    * Try to execute Test Connection with correct parameters only to get the above error every time

    Accessing the MigrationService.svc on the 3.7 project gives the error:
    Could not load file or assembly 'Telerik.Cms.Engine, Version=3.7.2136.2, Culture=neutral, PublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Which seems to agree with other posts in forums and such that the migration only works for 3.7 SP4. Is this the case still? What approach do I need to take to upgrade to 6.0? Migrate from 3.7 pre-SP4 to 3.7 SP4 first and then from that to 6.0? 3.7 pre-SP4 -> 3.7 SP4 -> 4.x -> ...? Another approach? There are links in the Upgrade Center for a Migration Webinar but it doesn't seem to exist from what I can ascertain.

    Thanks.
  2. Michael
    Michael avatar
    2 posts
    Registered:
    10 Jul 2013
    10 Jul 2013 in reply to Michael
    Link to this post
    Also, there is reference in various places to patches to move to 3.7. Is this to move to 3.7 SP4 from earlier versions of 3.7? If so where are these patches available? Thanks.
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    11 Jul 2013 in reply to Michael
    Link to this post
    Dear Michael

    As far as I remember 3.7 had to  be on SP4 to be taken up to 6.0. However I don't read this anymore in the upgrade instructions.

    http://www.sitefinity.com/developer-network/forums/migrating-from-3-x-to-4-x-/is-sitefinity-3-7-2022-2-0-=-3-7-sp4-

    QUOTE
    Hello Martin,The Sitefinity version 3.7.2022.2 is service pack 1 for Sitefintiy 3.7 which is running on .NET 2.0. In order to migrate to 5.x you should upgrade to the latest 3.7 SP which is running on .NET 4.0. You can download the patch form your account. Please take a look at the following forum thread:

    http://www.sitefinity.com/developer-network/forums/migrating-from-3-x-to-4-x-/from-where-to-download-3-7-sp4-

    Kind regards,
    Pavel Benov 
    the Telerik team

    UNQUOTE

    Markus


3 posts, 0 answered