+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Profile control Avatar uploads to random galleries

Profile control Avatar uploads to random galleries

7 posts, 0 answered
  1. Roberto Modica
    Roberto Modica avatar
    146 posts
    Registered:
    08 Feb 2008
    27 Mar 2012
    Link to this post
    Hi,

    I also think the way the default album is selected when uploading images is a bug, it should just default to nothing and force people to pick the correct album, but i guess that is another thread.

    When using the profile control, avatars that are uploaded appear in different albums instead of just going to a default one, not sure if this can be set anywhere.

    Rob
  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    30 Mar 2012
    Link to this post
    Hello Rob,

    We were not able to reproduce it on our side. After you uploaded an Avatar image, you select Content->Images and there you can see all of the images in the libraries. The Default library or the library where you choose to store your image is on the right side of the Images page. When you select it, the uploaded images should be there. For your convenience I'm attaching a sample video demonstrating the default behavior we're observing, please do not hesitate to let us know if we might be missing a step in reproducing the problem.

    All the best,
    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Roberto Modica
    Roberto Modica avatar
    146 posts
    Registered:
    08 Feb 2008
    30 Mar 2012
    Link to this post
    Hi,
    Sorry i wasn't clear, the front end user control where you press change photo to add an avatar, not the backend one, it uploads to a gallery that may have been used to select and image previously.

    So for instance i have a gallery called locations which i upload to, someone comes along and uploads an avatar after i have done the above, and then avatars seem to appear in that library and not the default one.

    Rob

  4. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    03 Apr 2012
    Link to this post
    Hi,

    After clarifying the desired scenario it seem that this is a bug. I have logged it in our internal bug-tracking system and I hope we will be able to provide a solution for the upcoming releases.

    Greetings,
    Stefani Tacheva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Robert
    Robert avatar
    70 posts
    Registered:
    05 Feb 2009
    07 Jun 2012
    Link to this post
    Hi I have similar problem. When changing avatar, the profile widget uploads photo to my first library which has slider images.

    Can you please elaborate more on the current behavior, so that perhaps I can workaround the problem? 

    Thanks,
    Robert
  6. Laura
    Laura avatar
    311 posts
    Registered:
    25 Feb 2008
    14 Jun 2012
    Link to this post
    Did anyone hear back  on this?   When we use the front end profile control, the avatar upload image uploads to the "Default" library.  Anyway to change where the avatar image is uploaded to? We don't want it uploading to the "Default" Library.
    Thank you.
  7. Robert
    Robert avatar
    70 posts
    Registered:
    05 Feb 2009
    19 Oct 2012 in reply to Laura
    Link to this post
    Hi, I just got an answer from support:

    There is a public property for the ImageField control, in the Edit Profile template, called AlbumId to which you can pass the Id of the image library for the avatars. You can get the Library Id with devTools like Firebug for Firefox for example. 

    And it actually works, but only for 'profile form ' template = you loose autogenerated fields

    Robert
7 posts, 0 answered