Try Now
More in this section

Forums / Bugs & Issues / Redirect from a library path not working

Redirect from a library path not working

2 posts, 0 answered
  1. Scott
    Scott avatar
    1 posts
    10 Jun 2015
    06 Nov 2015
    Link to this post


    We recently launched a new site for our customer, and as part of this are trying to redirect links to documents to their new path. 

    The old path looks like 'lib-docs/default-source/general-documents/document.pdf'

    The new path is 'docs/default-source/general-documents/document.pdf'

    So we created a redirect page accepting the first url and redirecting to the second, but we persistently get a 404 error when accessing the old URL.  Any advice on how to handle this within Sitefinity?

  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    21 Oct 2016
    11 Nov 2015
    Link to this post
    Hello Scott,

    This issue is caused by a bug in Sitefinity as described in the below KB articel:


    I am sorry for the inconvenience caused by this issue. As a workaround please use rewrite rules in your web.config file or redirect your users to the default document url in the Application Begin Request method in the Global.asax file.

    Sabrie Nedzhip
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
2 posts, 0 answered