+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Schedule Publish Not Working

Schedule Publish Not Working

2 posts, 0 answered
  1. Courtney
    Courtney avatar
    1 posts
    Registered:
    16 Dec 2013
    28 Oct 2015
    Link to this post

    We’re trying to schedule a page for publishing. It was scheduled to publish 10/28/15 at 15:30 (3:30pm).

    It did not. So we tested building a new page, and it’s saying the time of the page build is 03:36, despite the fact that it should be 15:36.

    We are not able to schedule publishing for 03:45 today now, because it’s thinking it is in the past and immediately publishing the page.

    Our time zone setting is set correctly to UTC -06:00 Central Time

    Please advise how we can schedule something to publish in the afternoon.

     We are on Sitefinity 8.0.

  2. Arnob Makhlaqur
    Arnob Makhlaqur avatar
    41 posts
    Registered:
    23 Sep 2016
    06 Nov 2015
    Link to this post
    Hello Courtney,

    To elaborate on this issue, more information is needed, like how the scheduler was set, through API or backend? After the page created what is the value for "date_created" column stored in sf_page_node table of the database and what was the local time when the page created? If that was perform through the custom scheduler then what are the codes of the custom scheduler?

    Usually if a page is created it stores the date created value with the time of UTC. In the Backend, the pages list view shows the page created value which retrieve from the database with the code; DateCreated.sitefinityLocaleFormat('dd MMM, yyyy hh:mm') which converts the UTC time to the local time zone and display this time at the last column. Here hh:mm displays the 12 hour time format without am/pm, so if it shows 3:36, the actual value of the created date time is correct and you can display the 24 hour time format by changing hh:mm to HH:mm. 

    It can be changed by going to Sitefinity Backend -> Administration->Settings->Advanced->ContentView->Controls->FrontendPages->Views->FrontendPagesListView -> ViewModes ->TreeTable -> Columns -> DateOwner

    In the list of of properties on the right-hand side of the screen change the ClientTemplate property value from:
    <span>{{ (DateCreated) ? DateCreated.sitefinityLocaleFormat('dd MMM, yyyy hh:mm') : '-' }}</span>                                   <span class='sfLine'>{{Owner ? Owner : ''}}</span>

    to:
    <span>{{ (DateCreated) ? DateCreated.sitefinityLocaleFormat('dd MMM, yyyy HH:mm') : '-' }}</span>                                   <span class='sfLine'>{{Owner ? Owner : ''}}</span>


    To schedule something to publish in the afternoon, set Publish/Unpublish on Specific date and select the date and time in the 24 hour format and it should work unless if it is through the API and there is any code which is using date_created value without converting the UTC time to the local time zone.

    Regards,
    Arnob Makhlaqur
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered