+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Server Error 404 - File or directory not found.

Server Error 404 - File or directory not found.

26 posts, 0 answered
  1. Patrik
    Patrik avatar
    5 posts
    Registered:
    28 Dec 2010
    08 Feb 2011
    Link to this post
    Hi,

    the face of a very mysterious problem. On the live server I uploaded the "empty project",installation was trouble-free, I entered everything needed to connect to the database.After logging in, seamlessly screen "Dashboard".

    The problem occurs when I try to choose an option. I wanted to convert the basicsettings of the project, but Sitefinity I get an error message "Server Error 404 - File or directory not found.". Once I checked that the server some files are missing, everything was fine.

    I changed the authorization in web.config, I forbade "Basic Authorization", did not help.

    So I tried again to upload the whole project again, installation went without problemsagain, but the problem was repeated.

    He met with by someone?

    Am I doing something wrong?

    I use version 4.0.1098.0 - Community

    I will be grateful for any idea.
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    11 Feb 2011
    Link to this post
    Hi Patrik,

    Can you please make sure that you have all the required windows features installed and running. For reference, please check this article. Most probably you have not enabled WCF.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Patrik
    Patrik avatar
    5 posts
    Registered:
    28 Dec 2010
    11 Feb 2011
    Link to this post
    On my local server Sitefinity works well, the problem occurs when I put the project onweb hosting.

    All necessary functions supported hosting.
  4. Patrik
    Patrik avatar
    5 posts
    Registered:
    28 Dec 2010
    12 Feb 2011
    Link to this post
    I updated web.config, I added the handlers *.svc and *.xamlx, chech the support WCF in my hosting, Sitefinity but I still have an error 404 File or directory not Foud.

    What's wrong?

    Handlers have mapped as follows:

    <httpHandlers>
          .
          .
          .
          <add verb="*" path="*.xamlx" type="System.Xaml.Hosting.XamlHttpHandlerFactory, System.Xaml.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
          <add verb="*" path="*.svc" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>

  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    12 Feb 2011
    Link to this post
    I have this exact issue with 4.0 standard as well, here are the entries in my web.config...

    <!-- CUSTOM -->
            <add name="svc-ISAPI-4.0_64bit" path="*.svc" verb="*" modules="IsapiModule" scriptProcessor="c:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="integratedMode" />
            <add name="xamlx-ISAPI-4.0_64bit" path="*.xamlx" verb="*" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" preCondition="integratedMode" />
            <add name="svc-Integrated-4.0" verb="*" path="*.svc" type="System.ServiceModel.Activation.HttpHandler, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
            <add name="xamlx-Integrated-4.0" verb="*" path="*.xamlx" type="System.Xaml.Hosting.XamlHttpHandlerFactory, System.Xaml.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode" />
          <!-- END CUSTOM -->
  6. Patrik
    Patrik avatar
    5 posts
    Registered:
    28 Dec 2010
    12 Feb 2011
    Link to this post
    One more clarification, after the update (as amended) the "web.config" file, it loads the "Advanced Settings", if I want to save the settings Sitefinity reporting a Error 404, the same thing happens when you try to create a new template,  upload the server file "template.master", upload takes place ok.

    When I go on, eg. save and return to a page with templates, action ends with Error 404 File or Directory not Found.

    By mistake my end all attempts at any change in the Sitefinity CMS improsed on Web hosting. On the local PC everithing works without any problems.

    I'm already desperate and the customer is furious as a bull (Im waiting, when ity comes to office :-) ).

    The only thing that calms me how tal are songs from Metallica :).



    Please, please and please help.
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    12 Feb 2011
    Link to this post
    I'm in the same boat my friend, site is totally useless on an editing front

    The ONLY thing I can suggest to you so they can at least move forward with editing, is to host it off your machine for now pointing to the webhosts DB...that seems to work for me, but it's slow....
  8. YASIR
    YASIR avatar
    3 posts
    Registered:
    25 Jan 2011
    14 Feb 2011
    Link to this post
    I got the same issue and found the solution finally by tracing the root of this issue.

    Problem's Root:
    This problem occurs because no verbs are added to the <verbs> section in the applicationHost.config file. Additionally, the allowUnlisted property of the <verbs> section is set to false. This setting denies all the requests that add verbs that are listed in the <handlers> section. The <handlers> section is under the <system.webServer> node in the applicationHost.config file.

    Following are the steps to resolve this issue:

    1. In a text editor, open the ApplicationHost.config file.
    2. The ApplicationHost.config file is in the following folder:
         %SystemRoot%\system32\inetsrv\config (usually on c:\windows\system32\inetsrv\config)
    3. Locate the <verbs allowUnlisted="false" /> tag.
    4. Change this tag to <verbs allowUnlisted="true" />.

    Cheers!

    If you do not want to allow all the unlisted verbs for security reasons, you can explicitly add these verbs. For example, you can replace the <verbs allowUnlisted="false" /> tag with the following code:
    <verbs  allowUnlisted="false">
        <add verb="GET" allowed="true" />
    </verbs>
  9. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    14 Feb 2011
    Link to this post
    Sadly...that did not seem to fix me up :/
  10. Patrik
    Patrik avatar
    5 posts
    Registered:
    28 Dec 2010
    14 Feb 2011
    Link to this post
    They do not really know what to do, so I managed to run a functional website build on Sitefinity.

    The original files ApplicationHost.config value is determined as follows:

    < slovesa allowUnlisted = "true" applyToWebDAV = "true" />

    Does anyone have any idea what could cause a malfuction?

    Thanks.
  11. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    14 Feb 2011
    Link to this post
    I'm at a loss too...I have a ticket in, no followup yet on it

    This host will literally make any change I want, but I just have no idea what to tell them to do
  12. YASIR
    YASIR avatar
    3 posts
    Registered:
    25 Jan 2011
    14 Feb 2011
    Link to this post
    It seems that you got this issue in different situation. I got this issue in Windows Server 2008 Standard, when I tried to do any operation through CMS backend (i.e. Image Upload, add content editor in page etc).

    Check the web server logs to find out helpful description for this issue related. Try to replicate the issue on Server's browser instead of remote location; you might get some more information there.

    Unfortunately, the alert message "Server Error 404 - File or directory not found." is not descriptive. I was getting this message only when I accessed the CMS from Internet; but when I accessed it locally on Web Server, it showed me the "404.6 HTTP - verb denied" error and that helped me a lot to find the actual issue.

    Regards.
  13. Anton Hristov
    Anton Hristov avatar
    8 posts
    Registered:
    15 Dec 2009
    30 Mar 2011
    Link to this post
    The error message "Server Error 404 - File or directory not found" popping up in the back end of Sitefinity might be due to the website being run in a Medium Trust environment. Changing the environment to Full Trust should resolve the issue.
  14. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    01 Apr 2011
    Link to this post
    Hi Guys,
    I had the same issue and it turned out to be a configuration issue in URLscan. In the URLscan logs I had the following:

    Client at xxx.xxx.xxx.xxx: URL contains '.' in the path. Request will be rejected.  Site Instance='1673214664', Raw URL='/Sitefinity/Services/Security/Users.svc/'

    After reconfiguring URLscan correctly everything worked.

    Hope this helps
    thanks
    Richard
  15. Adam
    Adam avatar
    5 posts
    Registered:
    26 Feb 2010
    06 Apr 2011
    Link to this post
    @Richard Turner

        "After reconfiguring URLscan correctly everything worked."

    I'm curious, what change did you make to your URLscan configuration? I was having this same issue and just discovered today that URLscan was causing this. I changed RejectResponseUrl= to RejectResponseUrl=/~* in the urlscan.ini file, setting that feature to logging only mode, which fixes the SiteFinity 404 issue, but I'd rather set a specific rule to explicitly allow whatever SiteFinity function is being blocked, instead of just disabling that security function in URLscan.
  16. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    07 Apr 2011
    Link to this post
    Hi Adam,

    The changes I made were "AllowDotInPath=1", also made sure "[AllowVerbs]" contained GET, HEAD, POST & PUT.

    thanks
  17. Jerami Tainter
    Jerami Tainter avatar
    27 posts
    Registered:
    29 Oct 2009
    23 Apr 2011
    Link to this post
    Once again another life saver...on IIS6 I had to do this and added the "." setting and adding the Put verb

    Thanks again fellas for this...Sitefinity really needs to document this.
  18. Jason
    Jason avatar
    23 posts
    Registered:
    17 Jun 2009
    21 Sep 2011
    Link to this post
    Hi,

    Can you please elaborate on your posted fix to the 404 problem?  is the AllowDotInPath=1 a string to add to the web.config file.  Also where do i place the HEAD GET POST PUT in "allowedVerbs".

    Apologies for being a bit dense, still learning this stuff.  

    Cheers
    Jason
  19. Adam
    Adam avatar
    5 posts
    Registered:
    26 Feb 2010
    21 Sep 2011
    Link to this post
    This is in the c:\Windows\system32\inetsrv\urlscan\URLScan.ini file (this particular fix applies only if you are using the URLScan plugin for IIS). Here is some documentation on that INI file:
    http://technet.microsoft.com/en-us/library/cc751376.aspx
  20. Jason
    Jason avatar
    23 posts
    Registered:
    17 Jun 2009
    22 Sep 2011
    Link to this post
    thanks for the reply Adam.  That might work well if it were local but unfortunately my site is on the web server and therefore i do not have a windows/system32 directory to search in.  Any help for a web based solution?

    Thanks
    Jason
  21. Adam
    Adam avatar
    5 posts
    Registered:
    26 Feb 2010
    22 Sep 2011
    Link to this post
    If you don't have remote server access your web host would need to make the change. Are you sure it's related to URLscan and not just a genuine 404 missing page? Did your host tell you they installed this plugin?
  22. John
    John avatar
    61 posts
    Registered:
    08 Jun 2012
    15 Mar 2012
    Link to this post
    I know this is an old thread, but I wanted to post a simpler solution that happened to work for us.

    We are port-forwarding requests from the internet to an internal server hosting a Sitefinity 4.3 instance. We were having the same issue with the workflow service calls. Our internal website is on a dedicated server (a virtual machine) and is bound to all IPs for the server (not to a specific domain). The internal site is a virtual application in the Default Web Site.

    We were able to fix the issue by adding an entry in our hosts file for the external domain name used to access the site, pointing to the localhost IP.

    Example hosts file entry:

    127.0.0.1   external.domain.com

    This was enough to trick Sitefinity into working for us. Hope it helps somebody else.

    -John
  23. John
    John avatar
    61 posts
    Registered:
    08 Jun 2012
    15 Mar 2012
    Link to this post
    I know this is an old thread, but I wanted to post a simpler solution that happened to work for us.

    We are port-forwarding requests from the internet to an internal server hosting a Sitefinity 4.3 instance. We were having the same issue with the workflow service calls. Our internal website is on a dedicated server (a virtual machine) and is bound to all IPs for the server (not to a specific domain). The internal site is a virtual application in the Default Web Site.

    We were able to fix the issue by adding an entry in our hosts file for the external domain name used to access the site, pointing to the localhost IP.

    Example hosts file entry:

    127.0.0.1   external.domain.com

    This was enough to trick Sitefinity into working for us. Hope it helps somebody else.

    -John
  24. Ray
    Ray avatar
    5 posts
    Registered:
    27 Mar 2014
    15 Jul 2015 in reply to Anton Hristov
    Link to this post
    How did you enable full trust mode?
  25. Ray
    Ray avatar
    5 posts
    Registered:
    27 Mar 2014
    15 Jul 2015 in reply to Anton Hristov
    Link to this post
    @Anton Hristov, How did you enable full trust?  Do you mean on the app_data folder?  iis setting?
  26. Velizar Bishurov
    Velizar Bishurov avatar
    143 posts
    Registered:
    30 Sep 2016
    20 Jul 2015
    Link to this post
    Hi,

    You can check the following msdn article about the asp.net trust levels.

    Furthermore you can check our documentation article about configuring IIS to host Sitefinity projects. Please go though the settings and compare them to your local settings.

    Regards,
    Velizar Bishurov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
26 posts, 0 answered