+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / ServicesPaths Issue

ServicesPaths Issue

2 posts, 0 answered
  1. Siddesh Kapadi
    Siddesh Kapadi avatar
    239 posts
    Registered:
    09 Oct 2009
    29 Jan 2013
    Link to this post

    Hi,

    I have a site that is hosted on production environment. The Url is similar to http://www.mysite.com. The issue I face is:

    Scenario 1:
    1. I go to adding a page.
    2. I select the template of the page.
    3. I add content to the page.
    4. I hit the button publish.
    5. I receive an error of : DefaultWorkflows/PagesApprovalWorkflow.xamlx
    6. To fix this, I go to: ServicePaths. Enter the WorkflowBaseUrl as: http://www.mysite.com
    7. I Save Changes and follow step 1-4. The pages publishes

    Excellent. It works. My Admin URL for above is: http://www.mysite.com/Sitefinity

    Scenario 2:
    For this Scenario, My Admin URL is: http://mysite.com/Sitefinity
    Steps followed are:

    1. I go to adding a page.
    2. I select the template of the page.
    3. I add content to the page.
    4. I hit the button publish.
    5. I again receive an error of : DefaultWorkflows/PagesApprovalWorkflow.xamlx
    6. The WorkflowBaseUrl is: http://www.mysite.com

    Is there a way to avoid this embarassment?

    Can we do away with WorkflowBaseUrl?

    Regards,
    Siddesh Kapadi
    (+91-983914008)


  2. Patrick Dunn
    Patrick Dunn avatar
    237 posts
    Registered:
    03 Nov 2014
    01 Feb 2013
    Link to this post
    Hi Siddesh,

    Thank you for contacting Sitefinity support.

    The problem is caused because Sitefinity is messaging the workflow internally, not from the same location from which you are trying to publish the item. This is why we've introduced the WorkflowBaseUrl setting which allows you to configure where the WorkflowService endpoint should be resolved.

    Would it be possible to share whit us some additional information on the specific use case scenario, namely how the site bindings are configured in IIS (you can provide a screenshot if possible), and if you have added references to the host header for this site in the hosts file on the server.

    In the meantime, what you can try is referencing the host headers for both bindings in the hosts file, for example:
    127.0.0.1   domainname.com
    127.0.0.1   www.domainname.com

    And remove the WorkflowBaseUrl setting. if any issues persist, please do not hesitate to let us know, we'll be glad to help you further.

    All the best,
    Patrick Dunn
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered