+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / SF 5.1+ Possible Bug: RadAsyncUpload Control #ResourceNotFound#

SF 5.1+ Possible Bug: RadAsyncUpload Control #ResourceNotFound#

7 posts, 0 answered
  1. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    05 Sep 2012
    Link to this post

    I started seeing this after upgrading to SF 5.1 SP1.  The Select/Cancel/Reset button on the RadAsyncUpload control no longer displays button labels.  Instead it displays #ResourceNotFound# (see the attached image). Oddly, the label displays correctly when in design not but not in runtime mode. As you might expect, the labels display properly if the "Localization-Cancel", "Localization-Remove", and "Localization-Select" properties are set manually.

    I first noticed this in an existing project and am able to reproduce in a clean new SF 5.1 SP1 project.  Not sure if the issue is present in 5.1 SP2.

    Markup is as follows:

    <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="test.aspx.cs" Inherits="SitefinityWebApp.test" %>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
        <div>
                 <asp:ScriptManager ID="ScriptManager1" runat="server">
            </asp:ScriptManager>
            <br />
     
            RadAsyncUpload
            Default Skin<br />
            <telerik:RadAsyncUpload ID="RadAsyncUpload1" runat="server">
            </telerik:RadAsyncUpload>
            <br />
     
            RadAsyncUpload
            Forest Skin<br />
            <telerik:RadAsyncUpload ID="RadAsyncUpload2" runat="server" Skin="Forest">
            </telerik:RadAsyncUpload>
            <br />
     
            RadAsyncUpload
            Black Skin<br />
            <telerik:RadAsyncUpload ID="RadAsyncUpload3" runat="server" Skin="Black">
            </telerik:RadAsyncUpload>
            <br />
     
            RadAsyncUpload
            Default Skin with Manually Set Localizaton Labels<br />
            <telerik:RadAsyncUpload ID="RadAsyncUpload4" runat="server" Localization-Cancel="Cancel" Localization-Remove="Remove" Localization-Select="Select">
            </telerik:RadAsyncUpload>
         
            <br />
            RadUpload Default Skin<br />
            <telerik:RadUpload ID="RadUpload1" Runat="server">
            </telerik:RadUpload>
         
        </div>
        </form>
    </body>
    </html>

    --Steve

  2. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    18 Sep 2012
    Link to this post
    Quick update: I'm also seeing this on 5.1 SP2.

    Steve
  3. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    21 Sep 2012
    Link to this post
    Hello SteveV,

    Thank you for contacting us and the provided info.

    The reason why you are getting this message on the buttons is that RadAsyncUpload control is not used anywhere in Sitefinity's architecture and since this is the case Sitefinity does not know about it and how to label it by default.

    Please find the attached language pack and import it. To do that go to the backend of your site-Administration->Interface Labels and Messages->Import Language pack. Reset the application by re-saving the web.config file and refresh the page with the RadAsyncUpload control.

    I hope this helps. Please let me know if you have any further questions.

    Kind regards,
    Pavel Benov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Stephen
    Stephen avatar
    15 posts
    Registered:
    06 Oct 2011
    26 Oct 2012
    Link to this post
    This same issue is is SF 5.2! We need the language pack for 5.2!!!
  5. Stephen
    Stephen avatar
    15 posts
    Registered:
    06 Oct 2011
    26 Oct 2012 in reply to Stephen
    Link to this post
    Okay I created a Language pack 5.2 :) email if you need a copy
  6. Miladin
    Miladin avatar
    3 posts
    Registered:
    28 Jan 2012
    03 Oct 2013
    Link to this post
    Hi,

    Can U please provide language pack for Sitefinity 6.1?

    I've used one provided here but it is now showing that my Sitefinity is version 6.0 on dashboard and I still get #resourceNotFound#:RadAsyncUpload:DropZone inside my async upload.

    Thanks in advance

    Sorry for this post - I wanted to put it in this thread http://www.sitefinity.com/developer-network/forums/bugs-issues-/radasyncupload-label-=-resourcenotfound#Hkz4rME3622pWP8AAERlJg but i missed. never the less if U can provide me that language pack in any of mentioned threads it would be much apprechiated.

    Cheers
  7. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    08 Oct 2013
    Link to this post
    Hi,

    Please take a look at the following thread on steps how you can create one for the version you are on:

    http://www.sitefinity.com/developer-network/forums/bugs-issues-/radasyncupload-label-=-resourcenotfound
     

    Regards,
    Pavel Benov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
7 posts, 0 answered