+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Site Sync Issue with Shared Content Block

Site Sync Issue with Shared Content Block

8 posts, 0 answered
  1. Robert
    Robert avatar
    1 posts
    Registered:
    02 Apr 2014
    23 May 2014
    Link to this post

    Hi,

    On our custom Sitefinity (6.3) Multisite project, we are using a shared content block across three page templates. On our development server, the CSS and content changes made within the Sitefinity shared content editor show up correctly. However, when we do a site sync to our production server, these changes are NOT SHOWING UP, even though the site sync status messages say that the shared content is synced.

    Is this a problem with in-memory caching or an issue with the sync process? Any help would be appreciated.

    I've bounced the app pool and restarted the production IIS server and it didn't fix the problem.

    Thank you!

  2. mike
    mike avatar
    15 posts
    Registered:
    21 Apr 2011
    23 May 2014 in reply to Robert
    Link to this post

    An add on to this, I'm pretty sure the problem is only with shared content, in our page template,  on the secondary sites (using multi-site) not the primary site. They appear to sync but the content never appears. We've republished the page template and pages to try to kick the cache. 

  3. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    26 May 2014
    Link to this post
    Hi Robert,

    Seeing how the problem only reproduces on templates, my guess is that you rely on master pages in your templates. Since master pages are items that are outside the Sitefinity database, they are not handled by our SiteSync module. Some other such items are:
    •         content
    o   Forms
    o   Forums
    o   Comments
    •         system data
    o   non-Database stored content - labels, themes, master pages, etc.
    o   configuration files (this includes customizations in the backend UI/view and fields definitions)
    o   configuration about data providers and provider settings
    o   custom backend pages
    o   users and roles 
    o   feeds / search indexes
    o   workflow definitions
    o   personalization settings
    o   responsive design settings

    Can you please confirm that this is the case and that you have followed the Documentation when attempting to sync your content?

    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  4. mike
    mike avatar
    1 posts
    Registered:
    17 Feb 2011
    27 May 2014 in reply to Ivan D. Dimitrov
    Link to this post

    I think you misunderstand the problem, this bug only appears on shared content blocks on the other sites (as defined in the multi-site admin). The first site we created has no problem sync'ing shared content.  In this instance it's the shared html block we use for the footer that won't sync and refresh on the other clusters. We have no problems syncing the physical master templates.

  5. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    29 May 2014
    Link to this post
    Hi Robert,

    The scenario where no exception is thrown when the sync executes and still content is not properly synced is only viable if your setup is incorrect. Please review this documentation article about the constraints and prerequisites of SiteSync. The point that applies to your scenario is "If you have multisite license, you must have the same sites, configured on both the target and the source servers. For more information, see Multiple site management."

    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  6. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    29 May 2014
    Link to this post
    Hi again,

    A miss-click caused me to omit the Prerequisites and Constrictions article. Here it is:

    http://www.sitefinity.com/documentation/documentationarticles/prerequisites-and-restrictions

    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Gaurav
    Gaurav avatar
    3 posts
    Registered:
    15 Apr 2015
    04 May 2015
    Link to this post
    I am having the same issue, Sitefinity 8, after sitesync when i log out from sitefinity i am not able to see any pages being rendered.
  8. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    08 May 2015
    Link to this post
    Hi,

    Please check your Error.log file for any errors which were logged during this period. I would also suggest you to restart your application and check whether everything will be working as expected then. If the problem still persist you can send screenshots or video demonstration. Moreover please use Developer Tool for Internet Explorer (it is built in the browser, click F12) or use Firebug (it is a plugin for Firefox) and check if you are getting some errors.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
8 posts, 0 answered