1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity 3.7 Issue with Extensionless URLs

Sitefinity 3.7 Issue with Extensionless URLs

3 posts, 0 answered
  1. Kerchal
    Kerchal avatar
    4 posts
    Registered:
    14 Apr 2011
    20 Apr 2011
    Link to this post
    We are currently in the process of upgrading from Sitefinity 3.2 to 3,7. In the 3.2 version of our site, we used extensionless urls. I have followed the instructions on page 199 and 205 in the UserManual_3_7.pdf from your site. We are using IIIS (Version 7.5.7600.16385). Our site was upgraded from .Net 3.5 to 4.0. When we try to access pages without extensions (.aspx), we are automatically directed to the 404.aspx page. Are there any other setting or code that will resolve this problem?

    Thanks,

    Kerchal
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    21 Apr 2011
    Link to this post
    @Kerchal

    This is the 4.0 Forum.

    If I remember correct for extensionless URL you needed to redirect your 404 to sf404.aspx on IIS without having a 'physical' sf404.aspx page. Might want to search the 3.7 forum. Probably find the answer there.

    @Admin - Can you move this thread?

    Markus
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    21 Apr 2011
    Link to this post
    Hello,

    Please take a look at Sitefinity's UserManual, section Extensionless URLs.
    Possible reasons for this error are:

    -Wrong setting of IIS for extensionless urls.
    -There is a something else on the website that misleads the url parser.

    sf404 should be configured in IIS as Error page/WildcardMapping or in the web.config as custom error.  This is the correct setup. If the problem persists you can try setting setrunAllManagedModulesForAllRequests attribute to true in your web.config



    Regards,
    Ivan Dimitrov
    the Telerik team

3 posts, 0 answered