+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity 5.1 there was no endpoint

Sitefinity 5.1 there was no endpoint

10 posts, 0 answered
  1. Eduardo
    Eduardo avatar
    3 posts
    Registered:
    10 Jan 2011
    23 Aug 2012
    Link to this post
    I have a page with Sitefinity 5.1, when I create a page I get the following error:

    There was no endpoint listening at PagesApprovalWorkflow.xamlx that could accept the message


    help me please
  2. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    29 Sep 2012
    Link to this post
    Hi,

    I am also facing the same issue.
    Any help would be really appreciated.

    Thanks! 
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    03 Oct 2012
    Link to this post
    Hello,

    The error is encountered if the system cannot find where the workflows is. We have a KB article which can help you:

    http://www.sitefinity.com/devnet/kb/sitefinity-4-x/pages-cannot-be-published-after-installation.aspx


    However, if the server / network environment is more complicated ( proxies, internal redirections / firewalls ) setting the WorkflowBaseURL might not help and we will need more detailed information to diagnose the issues.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    03 Oct 2012
    Link to this post
    Fixed .
    Thanks !
  5. gregory hernandez
    gregory hernandez avatar
    59 posts
    Registered:
    10 Jul 2009
    09 Apr 2013 in reply to Tarun
    Link to this post
    Tarun, if I may ask, how did you fix it?
    Thanks, Gregory Hernandez
  6. Tarun
    Tarun avatar
    81 posts
    Registered:
    14 Jan 2009
    09 Apr 2013 in reply to gregory hernandez
    Link to this post
    Hi Gregory,

    If i remember correctly, it was some url pointing issue. I fixed it through set value of ServicesPaths :http://176.13.22.540 (Server IP address). 

    You may find this field in tab : Administration> Settings > Advance > System > ServicePaths 


    Regards,
    Tarun
  7. jkregala
    jkregala avatar
    159 posts
    Registered:
    22 Sep 2009
    30 Apr 2013
    Link to this post
    Hello, the item in the KB article did not solve our issue with this. :(
  8. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    01 May 2013
    Link to this post
    Hello Jan,

    Even if setting the WorkflowBaseURL property correctly to your domain, you may still encounter the problem, if your environment is more complex. Therefore any additional information about the setup would be helpful when resolving the problem. Screenshots or details about how is your IIS set and also of the hosts file would be great.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Richard Baugh
    Richard Baugh avatar
    201 posts
    Registered:
    22 Aug 2012
    01 May 2013 in reply to Victor Velev
    Link to this post
    We have run into this on some of our servers. It just depends on firewalls and proxies as Victor mentioned. One thing you could try instead of the WorkflowBaseURL is to add an entry to your hosts file. (C:\Windows\System32\drivers\etc\hosts) We add an entry for the domain and point it to the local loopback ip of 127.0.0.1

    127.0.0.1    www.domain.com

    If you access the site with an without the "www" host header, then you would need to add an entry for the domain with and without the "www". The hosts file does not allow for wildcards, so each subdomain will need to be added in.

    I will mention that this does need admin rights to edit. So if you open notepad or another text editor program, you will need to run it as an administrator in order to save your changes.
  10. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    03 May 2013
    Link to this post
    Hi Richard,

    Thank you for sharing the additional information - I believe that it would be helpful to everybody who encounters the problem.

    All the best,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
10 posts, 0 answered