+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity 5.x - Creating a New Project, hangs during Set Database Step

Sitefinity 5.x - Creating a New Project, hangs during Set Database Step

4 posts, 0 answered
  1. Tahir
    Tahir avatar
    16 posts
    Registered:
    02 Jul 2012
    05 Sep 2012
    Link to this post
    Hi,

    As per the title, I am no longer able to create projects through the Sitefinity Project Manager.  This was working fine several weeks ago when I installed Sitefinity on my dev laptop however now I am no longer able to create projects successfully it seems.

    These are the steps I take:

    1. In Project Manager, click "Create New Project"
    2. 'File System' selected, click on  Browse > IIS > Create new Web Application called {my_project_name}
    3. Choose "Community" license and continue
    4. Set Project Name etc
    5. Sitefinity Project Manager indicates it is creating the necessary files in the location (files are created successfully)
    6. Right-Click the project and either click on Browse or 'Go To Administration...'
    7. 'Project Startup' wizard is displayed prompting for Database Details
    8. Enter my local MSSQL Server details (SQL 2008 R2 Developer Edition)
    9. Press 'Next' to proceed

    It is at step 9 that Sitefinity hangs, it appears to be going through the step to create the database but does nothing at all and eventually times out.

    I know it's a DB connection issue but how? I have tried both Windows Auth and SQL Auth and no change, in both instances it just sits there however I have confirmed the Database Server is active and I am able to connect to it using either authentication method.

    I am tempted to wipe everything and start again however thought I would check on the forum first before doing so.

    Thanks in advance.

    T
  2. Tahir
    Tahir avatar
    16 posts
    Registered:
    02 Jul 2012
    05 Sep 2012
    Link to this post
    Okay looks like I managed to answer my own question and fix it.

    Seems my IIS 7.5 App Pool identities had all reset for one reason or another hence nothing was working.

    I was using Network Services OR a local account for authentication and this was no longer valid.  Reset the ASP.NET 4.0 App Pool identity back to ApplicationPoolIdentity and then specified 'localhost' as the DB server name during setup with SQL credentials to get this working.

    If I use Windows Auth method and specify a server name (in my case the hostname of my machine) I need to make sure I have the above set i.e. a valid account that can be used by IIS to communicate and authenticate with my SQL server otherwise you get the issues I experienced.

    Hope this helps someone!
  3. Tahir
    Tahir avatar
    16 posts
    Registered:
    02 Jul 2012
    05 Sep 2012
    Link to this post
    Okay this is getting annoying, is it really this slow to develop with?

    I am getting time outs when trying to do anything locally, this is starting to put me off what should be a great product...
  4. Tahir
    Tahir avatar
    16 posts
    Registered:
    02 Jul 2012
    28 Sep 2012
    Link to this post
    For anyone who experiences this, you need to setup some firewall rules and/or allow the IIS worker process to run uninterrupted.

    1. Create an inbound rule for all programs on any TCP port for the local ip address of that machine only (either 127.0.0.1 [localhost] or the specific ip address of the IIS server/workstation).

    2. Create an outbound rule as well, same as above only for the specific ip address of the IIS server or workstation.

    This will resolve most performance issues and Sitefinity should run as intended.
4 posts, 0 answered