+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity 6.2 Analytics Not Setup upon returning to Analytics page

Sitefinity 6.2 Analytics Not Setup upon returning to Analytics page

5 posts, 0 answered
  1. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    28 Oct 2013
    Link to this post
    I have gone through Sitefinity's Analytics configuration 2x now and both times I was able to see my analytics displayed immediately after finishing the configuration. However, upon returning to the Analytics page I again am told "Analytics has not been configured yet" and my only option is to go through the configuration again. This says to me that my configuration settings are not being saved. 

    How do I resolve this issue?
  2. Pavel Donchev
    Pavel Donchev avatar
    28 posts
    Registered:
    06 Dec 2012
    30 Oct 2013 in reply to Chris
    Link to this post
    The AnalyticsConfiguration.config file should contain the data needed for the analytics. If you're able to see it the first time then the config should be OK. Do you immediatelly get analytics broken or after a certain amount of time? The analytics service needs a token that should be refreshed, I think the interval is about an hour, is it possible that the token gets invalid?
  3. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    31 Oct 2013
    Link to this post
    Hi,

    We have answered you in the support ticket you have opened. Once the problem is resolved you could share the  solution with the community.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Beth
    Beth avatar
    25 posts
    Registered:
    20 Aug 2012
    12 Dec 2013 in reply to Stefani Tacheva
    Link to this post
    Is there a solution?
  5. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    21 Nov 2016
    17 Dec 2013
    Link to this post
    Hello,

    Please find our answer in the support ticket that Chris submitted:

    Could you please inform us did you go over the official Sitefinity upgrade documentation?

    http://www.sitefinity.com/documentation/documentationarticles/upgrading-your-sitefinity-6.1-project-to-the-latest-version

    Could you please make sure you’ve followed all steps correctly, including the last paragraph which elaborates about the changes introduced in the Analytics module with Sitefinity 6.2 and the corresponding configuration settings that need to be performed after upgrade?

    After you upgrade Sitefinity to 6.2, the Sitefinity connection to the Google Analytics module is reset. You must configure the connection again. To do this, you must first register then setup the Analytics module.
    For more information, see Register the Analytics module and Setting up Analytics.


    Note that all configurations described in steps 6 should be applied in your web.config files.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered