1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity Error

Sitefinity Error

5 posts, 0 answered
  1. Dhaval
    Dhaval avatar
    21 posts
    Registered:
    23 Apr 2012
    27 Apr 2012
    Link to this post
    I have created one new project using Sitefinity Project Manager.
    Now when i browse that project
    1)it ask for the Setting Database.
    2) In that  I have given the Sql Server 2005/2008 and I have also given the  Database  Name
    3) After that I have given the Server name and i have not checked that windows    Authetication      becasue i am using the Sql  Server authentication.
    4) NOw when I click on the continue button it ask me for the Administrator Details i have also given that details
    5) Now when i click on the next button it gives me error that...
       

    The specified role "Administrators" already exists.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Configuration.Provider.ProviderException: The specified role "Administrators" already exists.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ProviderException: The specified role "Administrators" already exists.]
       Telerik.Sitefinity.Security.Data.OpenAccessRoleProvider.CreateRole(Guid id, String roleName) +447
       Telerik.Sitefinity.Web.UI.Backend.AdministratorPane.EnsureRole(RoleDataProvider roles, RoleInfo role) +429
       Telerik.Sitefinity.Web.UI.Backend.AdministratorPane.DoWork() +95
       Telerik.Sitefinity.Web.UI.Backend.StartupWizard.wizard_FinishButtonClick(Object sender, InternalWizardNavigationEventArgs e) +146
       Telerik.Sitefinity.Web.UI.Backend.InternalWizard.OnFinishButtonClick(InternalWizardNavigationEventArgs e) +96
       Telerik.Sitefinity.Web.UI.Backend.InternalWizard.OnBubbleEvent(Object source, EventArgs e) +540
       System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args) +37
       System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +107
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +161
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +9
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +174
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4645
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.237


    6) please give me some suggestion to solve this problem..

    Thank you.
  2. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    27 Apr 2012
    Link to this post
    Dhaval,
    It sounds to me like you are giving it a Database which is not empty. In other words a Database that has already been configured. If you create a new project, then this is what I do:
    1 - Go to your SQL Server, and create an empty database. Just right click -> New Database... -> Then give it a name.
    2 - Now when you create a new project, give it the name of your new database.
    Then the Project Manager detects that it is an empty database and creates the first Admin.

    When you create a new project, the configuration files say that there is no Admin specified yet, but when the Project Manager tries to create one, it finds that there one exists already. And that is how it gets confused. I had it happening to me.

    Hope it helps,
    Andrei
  3. Dhaval
    Dhaval avatar
    21 posts
    Registered:
    23 Apr 2012
    27 Apr 2012
    Link to this post
    Andrei
    yes that's true...
    I am giving the Database because it ask me to give..
    I have created the site in the older version and i want to convert that to the newer version.
    And i want to change the version of the project to 3.7 to 5
    so i have already created the database for that project now i want to convert my site to the older version to the new version. so i have directly given that database.
     Is it Work?
    If not Then what colud be the proper steps to make it work.
    thanks for the reply...
  4. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    27 Apr 2012
    Link to this post
    Sorry, didn't realise you were upgrading a 3.7 site to 5.0. In all honesty, I have never had to upgrade sites from 3.7, so I cannot advise you on that. If you have a license, then get in touch with Telerik via the support channel.
    Sorry,
    Andrei
  5. Dhaval
    Dhaval avatar
    21 posts
    Registered:
    23 Apr 2012
    27 Apr 2012
    Link to this post
    Andrei
    Its Ok. No problem.
    Thanks
5 posts, 0 answered