Try Now
More in this section

Forums / Bugs & Issues / SiteFinity slow page loads

SiteFinity slow page loads

3 posts, 0 answered
  1. Bryan
    Bryan avatar
    2 posts
    06 Aug 2012
    14 Oct 2012
    Link to this post
    Hello everyone,

    I am having a very worrisome issue with SiteFinity startup times. I've seen several posts about how long it takes to open a page the first time, but none of them have a solution that works for me. Each page takes 7-10 minutes to load the first time I open it. The "Pages" section of the control panel takes 15 minutes. If I were to go from the login page to the dashboard, to "settings" under administration, that would take be approximately a half hour.

    I am developing with Visual Studio 2010 and switching between the Cassini server and an IIS express instance. Both of them have roughly the same performance. My laptop is running Windows 7 and has 8 cores and 8 Gigs of ram. I use MS SQL Server express as my development database.

    I have noticed that every time I make a request to the SiteFinity website, csc.exe pegs out a CPU core for most of the waiting time. I've read online about people with slow startup times due to ASP.NET compilation, but only in a matter of seconds, not minutes.

    Now this problem didn't always happen, but it started this past week. The only thing I tried to do differently was add a custom user control to the SiteFinity toolbox. However, I've created new projects, updated from 4.2 to 5.1, used different databases, and I still get these long startup times.

    Does anyone know what my issue is? I need help!

    - Bryan Johnson
  2. Tahir
    Tahir avatar
    16 posts
    02 Jul 2012
    15 Oct 2012 in reply to Bryan
    Link to this post

    I am assuming you are developing locally like I do.  You need to check your firewall settings and see if anything is blocking IIS (specifically the worker process), this is the cause of the major slowdown.

    I added a new inbound/outbound rule in Windows Firewall for my local ip address (, yours may be specific to your PC and network.

    Set the rules to allow all TCP traffic and then restart IIS - you should notice an immediate performance difference (the initial start up times can be slow when Sitefinity is building the cache).

    Hope the above helps.

  3. Bryan
    Bryan avatar
    2 posts
    06 Aug 2012
    16 Oct 2012
    Link to this post
    Thanks for the idea, unfortunately adding inbound/outbound rules for my firewall did not help. I also tried to disable my firewall completely to see if that would work.

    I pulled out ProcMon and tailed the csc.exe process to see what it was doing. The compiler was spending 90% of its time in the registry working with a Microsoft Cryptography Provider. My company has some security software on my machine and was probably trying to process the libraries being compiled by SiteFinity.

    I decided to grab a virtual machine and just try out a bare-bones computer with little security. It worked. At least I'm compiling and moving.

    So this might be a better question to put to another forum, maybe an ASP.NET forum or my company's IT team.

    Thanks for the help
3 posts, 0 answered