+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Sitefinity Upgrade from 6 to 9.1 "White Screen of Death"

Sitefinity Upgrade from 6 to 9.1 "White Screen of Death"

1 posts, 0 answered
  1. Jack
    Jack avatar
    0 posts
    Registered:
    24 Aug 2016
    31 Aug
    Link to this post

    I am trying to upgrade from Sitefinity version 6 to 9.1. 

    Locally the project upgraded perfectly. It runs both on front end and back end.

    When I try to push my project server side, I upload:

    1. web.config (merged changes)
    2. bin folder contents (dll's)
    3. resource packages folder (because of Sitefinity feather to clear out a different upgrade error)

    After uploading all of this server side and spin up the site, I get a blank white screen with nothing on it. Chrome's developer console is telling me it's a 500 error. Is there something I'm missing? Also, is there a way I can clear out the 500 error and see the real issue? Custom errors is turned off in my web.config.

    I'm calling this the "White Screen of Death" because I've experienced this issue twice in a row and it brings nothing but despair.

    Please help! 

    Thanks.

     

    UPDATED SOLUTION: 8/31/2016
    I was comparing the web.config of my local C project and the server side project and noticed some code that was strange:

        <!--<rewrite>
          <rules>
            <rule name="HomeRedirectRule" stopProcessing="true">
              <match url="^home$" ignoreCase="true" />
              <action type="Redirect" redirectType="Permanent" url="/" />
            </rule>
          </rules>
        </rewrite> -->

    This code was actually preventing me from initializing the upgrade. I'm not sure what the redirect is for or why it's there. I ended up commenting it out and now the upgrade is initializing. 

    If anyone has had similar problems, feel free to share.

     

1 posts, 0 answered