+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Specified argument was out of the range of valid values. Parameter name: utcDate

Specified argument was out of the range of valid values. Parameter name: utcDate

3 posts, 0 answered
  1. Gérald
    Gérald avatar
    6 posts
    Registered:
    15 Jul 2010
    13 Nov 2013
    Link to this post
    After updating a CSS file on the server, I got this exception for a few minutes:

    System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.Parameter name: utcDate   at System.Web.HttpCachePolicy.UtcSetLastModified(DateTime utcDate)   at Telerik.Sitefinity.Web.RouteHelper.SetFileCacheability(HttpContext context, String file)   at Telerik.Sitefinity.Web.WebsiteTemplatesHttpHandler.ProcessRequest(HttpContext context)   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()   at
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&
    completedSynchronously)
  2. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    14 Nov 2013
    Link to this post
    Hello Gérald,


    I have revised your error log and it appears that it is provided an incorrect date to a system library. We have encountered this problem before when the date/time on a dependent assembly is incorrect. Can you check your computers date/time?
    Can you also test if this is happening on a particular web browser? You can try to clear your browser cache and also restart your system.

    Regards,
    Vassil Vassilev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Gérald
    Gérald avatar
    6 posts
    Registered:
    15 Jul 2010
    17 Jan 2014 in reply to Vassil Vassilev
    Link to this post
    When it's 12h00 on my computer (dev computer), it's 11h55 on the server. So when I deploy the css file, the new file has a future date. Maybe this can explain the issue.
3 posts, 0 answered