+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / SSL creates redirect loop

SSL creates redirect loop

6 posts, 0 answered
  1. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    07 May 2012
    Link to this post
    Hi all,
    Just looking to see if anyone else has encountered this issue. (I did put in a support request also). I created a page and set Require SSL to true. However, this creates a redirect loop and the page will not open.

    This does not occur when I access the page internally from within the network where the site is hosted. However, any external attempts result in the redirect.  I"m assuming it has something to do with server or firewall settings, but I don't know enough about how Sitefinity forces the SSL redirect to know.

    Any ideas on fixes would be greatly appreciated. Thanks!
  2. Muhammad Amod
    Muhammad Amod avatar
    1 posts
    Registered:
    04 Mar 2010
    22 May 2012
    Link to this post
    I am having the exact same problem. The server or firewall sending the site to https:// and the SF page redirecting back to http://
  3. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    22 May 2012
    Link to this post
    Hi
    We've found that it is something in Microsoft ISA. We still haven't found what exactly it is causing the issue.
    We set up a completely seperate ip with a different firewall and the site worked fine. We might get to more troubleshooting later this week and I'd be happy to let you know what we discover.

  4. Rico
    Rico avatar
    88 posts
    Registered:
    30 Aug 2012
    03 Jun 2013 in reply to Amanda Shafer
    Link to this post
    Came across the same issue -- Can you let me know if you managed to resolve this somehow/someway?
  5. Amanda Shafer
    Amanda Shafer avatar
    198 posts
    Registered:
    12 Oct 2012
    04 Jun 2013
    Link to this post
    I know this isn't any help, but we never did find out the issue. We ended up taking it out of our normal company firewall and setting it up on its own line with a physical firewall of its own.
  6. Michael
    Michael avatar
    67 posts
    Registered:
    16 Mar 2012
    05 Jun 2013
    Link to this post
    Does the actual page have "RequireSSL" set to true in it's properties? Otherwise it will always redirect to the non-secured page location when you try and hit it. I agree, it's kind of a bad design, but you improved SSL handling is on the roadmap supposedly for a future version.

    Note, there are posts around with code examples of how to loop through and set every page to RequireSSL = true, and if you want that to be the default you can compile a custom PageService for pages and set the page service to use yours and always set RequireSSL to true on making a new page.
6 posts, 0 answered