+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / SSL Redirect loop after setting non-default site URL

SSL Redirect loop after setting non-default site URL

11 posts, 0 answered
  1. Josh
    Josh avatar
    18 posts
    Registered:
    17 Nov 2008
    30 Oct 2013
    Link to this post
    We are using the Login/Log Out Button Widget which points to a login page that is set to require SSL. To this point it has worked.

    Because of a problem we are having with the campaign email module (the emailer sometimes sets the images and links to localhost rather than the accurate hostname), support has suggested setting the host name in the Advanced Settings under System > Site URL Settings > Non-default site URL.

    When this setting is enabled clicking on the Login/Log Out button causes an infinite redirect loop.

    Has anyone seen this or have a fix?
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    30 Oct 2013 in reply to Josh
    Link to this post
    Which version?
  3. Josh
    Josh avatar
    18 posts
    Registered:
    17 Nov 2008
    30 Oct 2013
    Link to this post
    6.0.4210.0
  4. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    30 Oct 2013 in reply to Josh
    Link to this post
    That widget has been updated a lot since 6.0, any chance you can get up to 6.2?
  5. Josh
    Josh avatar
    18 posts
    Registered:
    17 Nov 2008
    30 Oct 2013 in reply to Steve
    Link to this post
    OK, that's useful info.  I'll look into updating.
  6. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    30 Oct 2013 in reply to Josh
    Link to this post
    Well there was a bug where like if you were logged in with firefox, then you tried chrome it would do an infinite redirect...maybe it's that one, maybe not...but I've struggled with this control for a bit :/
  7. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    04 Nov 2013
    Link to this post
    Hello,

    There was a bug in Sitefinity login widget for an endless loop when maximum number of concurrent users was reached (this is fixed in our latest release).
    In case you upgrade your project, please follow our upgrade documentation and If the problem persists, please open a support ticket to further investigate this issue.
     

    Regards,
    Vassil Vassilev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Benjamin
    Benjamin avatar
    2 posts
    Registered:
    04 Jun 2013
    30 Dec 2013 in reply to Josh
    Link to this post
    We are having the same exact issue.  It seems like there are issues with how Sitefinity handles pages that have SSL turned on.  If we manually change the URL to HTTPS/HTTP (depending on if SSL is turned on for that page) then the site loads correctly.  For us, this issue is not browser specific.  It occurs in Chrome, Firefox, and IE.

    Any thoughts?  Did you ever get this working for you?  We'd like to get our email campaigns having the correct URLs without breaking our site.
  9. Josh
    Josh avatar
    18 posts
    Registered:
    17 Nov 2008
    30 Dec 2013
    Link to this post
    Hi Benjamin

    We just completed upgrading the site to version 6.3 this past weekend.  We had started the upgrade process to 6.2 as suggested here and by support, then 6.3 came out as we were about to push it out, so we decided to go all the way.

    The upgrade didn't directly fix the campaign issue with localhost links. However it does appear to have corrected the redirect loop. This allowed me to enable the non-default site URL setting and record the host name for our site in Settings > Advanced > System > Site URL Settings.  With those settings in place my Initial tests of the campaign emailer have been successful.  I'm planning to test again over the next couple of days as the locahost link problem has always appeared after a period of uptime.

    Regards
    Josh
  10. Benjamin
    Benjamin avatar
    2 posts
    Registered:
    04 Jun 2013
    30 Dec 2013 in reply to Josh
    Link to this post
    Hi Josh,

    Unfortunately, we can't upgrade at this time.  When we change the Site URL Settings we can get the email campaign working correctly.  We just have to make sure that when we browse the site after that we manually change the URL to HTTPS.  We have "Require SSL" checked for all of our frontend pages but our backend in not secured currently (just the login page).  The process that normally checks for that setting seems to be broken when the Site URL Settings are set.

    Thanks,
    Ben
  11. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    02 Jan 2014
    Link to this post
    Hello Benjamin,

    The upgrade is highly recommended as this is fixed in Sitefinity`s latest release. The other option is not to use "Enable non-default Site URL Settings" or to try setting some rewrite rule in your webconfig to avoid manually changing the URL.

    Regards,
    Vassil Vassilev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
11 posts, 0 answered