+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Telerik RadGrid Issue

Telerik RadGrid Issue

1 posts, 0 answered
  1. Janani
    Janani avatar
    1 posts
    Registered:
    20 Mar 2015
    20 Mar 2015
    Link to this post


    We have a requirement to update the RadGrid from JavaScript and partial page post back should happen.We have placed the button, RadGrid  everything inside an update panel.  we couldn’t get the RadGrid details from JavaScript by below code
    Since we are using  Assembly="RadGrid.Net2" Namespace="Telerik.WebControls".

    Currently we are using version RadControls for Asp.Net QC 2007  and the below highlighted code will work for Assembly="Telerik.Web.UI”

    var masterTable= $find("<%= RadGrid1.ClientID%>").get_masterTableView();
    masterTable. Rebind();

    We tried few other approaches and
    got stuck in between. Please help us to move further.

    Approach 1:

    We placed a hidden button and calling
    the method to update the grid from JavaScript on button click event. Though the
    button, RadGrid are inside update panel, post back is happening.

    Approach 2:

    Through xmlhttp request, sending
    the request to code behind and updating the grid controls.

    JavaScript:

    xmlhttp. Open("POST",
    url, true);

    xmlhttp.send();



    Code Behind:

    RadGrid1.DataSource = <new datasource>;

    RadGrid1.Rebind();



    Also we have tried similar
    approaches using PageMethods, XMLHttpRequest with Ajax call and XMLHttpRequest without Ajax call.



    In all these approaches No post
    back is happening and the new data source is also updated. we can see the
    new values in debug mode but the Grid is not refreshed with new values.


    Kindly do the needful with the
    same version of Telerik control, in case we have to update the version, please
    let us know the details.






1 posts, 0 answered