+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Telerik.Sitefinity.DynamicTypes.Model.XXX.XXX Parameter name: component Actual value was Telerik.Sitefinity.DynamicTypes.Model.XXX.XXX

Telerik.Sitefinity.DynamicTypes.Model.XXX.XXX Parameter name: component Actual value was Telerik.Sitefinity.DynamicTypes.Model.XXX.XXX

7 posts, 0 answered
  1. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    20 Feb 2014
    Link to this post

    Hi,

    I am getting this error when importing localized content in the dynamic module

    Telerik.Sitefinity.DynamicTypes.Model.XXX.XXXX Parameter name: component Actual value was Telerik.Sitefinity.DynamicTypes.Model.XXX.XXXX

    Daniel posted a fix for this for v6.2 but its not fixed in v6.3

    http://www.konstrui.nl/over-ons/blog/daniel-plomp/2013/12/10/create-multilingual-dynamic-content-items-(including-bugfixes)

    Please help

    Thanks

  2. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    20 Feb 2014
    Link to this post
    Hi Zubair,

    That is strange. I did not had the issues anymore within 6.3?
    Maybe support knows what is wrong. You sure that the Telerik.Sitefinity.Model.dll you are referencing is the right version?

    The link to my blogpost was not correct, so if anyone needs this solution, please use this url: http://knstr.it/GHFtme

    Kind regards,
    Daniel
  3. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    05 Dec 2016
    21 Feb 2014
    Link to this post
    Hello Zubair,

    Can you please verify the Sitefinity version you are using is indeed 6.3 ? The bug has been officially fixed for 6.3, so i case you are indeed reproducing it on that version would it be possible to outline the exact steps you're taking so we can verify it locally and ensure everything is OK or take the appropriate actions?

    Regards,
    Boyan Barnev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  4. Zubair
    Zubair avatar
    142 posts
    Registered:
    26 Dec 2007
    21 Feb 2014 in reply to Boyan Barnev
    Link to this post

    Indeed the version I quoted was wrong, I upgraded my solution from 6.1 to 6.3 and the problem is fixed.

    Thanks

  5. Stephen2
    Stephen2 avatar
    94 posts
    Registered:
    05 Feb 2012
    06 Nov 2014 in reply to Zubair
    Link to this post

    Hi Boyan & Sitefinity,

    Behaviour continues up to 7.2.5310 when using SitefinityQuery.Get to retrieve Dynamic Content items.  Only on 1st access.  2nd access produces no error.

    Can this please be logged as bug?

     

    Thanks,

    Stephen

  6. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    05 Dec 2016
    06 Nov 2014
    Link to this post
    Hi Stephen,

    That's an interesting finding! Can you please share with us the implementation you're using so we can check this out? Keep in mind SitefintiyQuery is a rather low level mechanism of doing things, moreover it bypasses some security checks, and in general the behavior might vary compared to using the managers. Still, we'd like to check this out and see if there's anything we can find and fix, for sure, I just wanted to recommend sticking to the official managers API, unless the use case cannot be achieved with them.

    Regards,
    Boyan Barnev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  7. Stephen2
    Stephen2 avatar
    94 posts
    Registered:
    05 Feb 2012
    06 Nov 2014 in reply to Boyan Barnev
    Link to this post

    Sure mate, have a read of this post, it describes why I use this function:

    http://sitefinitydownunder.com/blogs/stephen-pittman/2014/03/02/multisite-coding-changes-and-query-performance

     

7 posts, 0 answered