+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The ContentViewDefinition with name * does not exist in configuration files

The ContentViewDefinition with name * does not exist in configuration files

8 posts, 0 answered
  1. Jack
    Jack avatar
    7 posts
    Registered:
    30 Oct 2013
    09 May 2014
    Link to this post

    Hi i'm getting the following error when trying to view one of my content items. This seems to have just happened by itself. It was working a short time ago but then i came back to it and it's not loading. I've checked the config files for changes but nothing has occured. Looking in DynamicModulesConfig.config everything seems to be there so not sure what the issue coould be.

    Any help would be awesome, thanks!

    The ContentViewDefinition with name 'Telerik.Sitefinity.DynamicTypes.Model.Charts.BarDatasetBackendDefinition' does not exist in configuration files.
               You should either add the ContentViewDefiniton with such name to the configuration;
               change ControlDefinitionName or load ControlDefinition programmatically by setting
               the ControlDefinition property.
     
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
     
    Exception Details: System.InvalidOperationException: The ContentViewDefinition with name 'Telerik.Sitefinity.DynamicTypes.Model.Charts.BarDatasetBackendDefinition' does not exist in configuration files.
               You should either add the ContentViewDefiniton with such name to the configuration;
               change ControlDefinitionName or load ControlDefinition programmatically by setting
               the ControlDefinition property.
     
    Source Error:
     
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
     
    Stack Trace:
     
     
    [InvalidOperationException: The ContentViewDefinition with name 'Telerik.Sitefinity.DynamicTypes.Model.Charts.BarDatasetBackendDefinition' does not exist in configuration files.
                You should either add the ContentViewDefiniton with such name to the configuration;
                change ControlDefinitionName or load ControlDefinition programmatically by setting
                the ControlDefinition property.]
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.get_ControlDefinition() +249
       Telerik.Sitefinity.Web.UI.ContentUI.BackendContentView.get_ControlDefinition() +5
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.ResolveContentManager() +36
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.ResolveDetailItem() +142
       Telerik.Sitefinity.Web.UI.ContentUI.ContentView.CreateChildControls() +59
       System.Web.UI.Control.EnsureChildControls() +83
       System.Web.UI.Control.PreRenderRecursiveInternal() +42
       System.Web.UI.Control.PreRenderRecursiveInternal() +168
       System.Web.UI.Control.PreRenderRecursiveInternal() +168
       System.Web.UI.Control.PreRenderRecursiveInternal() +168
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +974

  2. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    10 May 2014
    Link to this post
    Hello Jack,

    A possible cause for this error could be insufficient permissions to your App_Data folder, thus when you have created the dynamic module, Sitefinity was unable to properly outline it`s structure in your config files.
    If this happens on a brand new project, a permission issue is the most likely reason for this, so make sure your application pool identity has read / write access as defined in our onlyne documentation:
    http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/install-sitefinity/configuring-the-iis-to-host-sitefinity-projects

    If this is an upgraded project, then obviously something went wrong during the upgrade (again could be a permission issue or else) and the best resolution is to perform the upgrade sequence again.

    To summarize, for some reason DynamicModulesConfig.config was corrupted (has missing nodes in it). If it`s not due to upgrade I could advise you to recreate the module (could be on a brand new project) and compare the config generated with the one from your project. Note that when you modify your config file, always keep a backup copy of them.

    I hope this information helps.

    Regards,
    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Jack
    Jack avatar
    7 posts
    Registered:
    30 Oct 2013
    12 May 2014 in reply to Vassil Vassilev
    Link to this post

    Hi Vassil thanks for the reply.

    The site is about 3-4 months into build at the moment and all permissions are ok on App_Data.
    This has been fine up until now and is just this one content item. Looking back through version control of what has been changed i can see nothing related to the content item in question. This makes me think that there may be a database component to the issue, or something outside of the config files - maybe some conflicting code.

    We did upgrade to v7 when it was launched (due to some required functionality) but this was some weeks back. I'm gonna try exporting the content item, deleting it and re-importing - as a colleague said this worked for him. I'll report back if i get it working - luckily no content has been added for this item yet !!

  4. Ed
    Ed avatar
    20 posts
    Registered:
    26 Mar 2013
    12 Mar 2015 in reply to Jack
    Link to this post
    I'm having the same problem. I was able to use this module long enough to add a few pieces of content. Came back the next day to add more, and now I get this error too. This is disconcerting. Any ideas, anyone?
  5. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    17 Mar 2015
    Link to this post
    Hi Ed,

    Could you please check your content view config for the module record:
    <config:link definitionName="Telerik.Sitefinity.DynamicTypes.Model.Pressreleases.PressReleaseBackendDefinition" path="dynamicModulesConfig/contentViewControls/Telerik.Sitefinity.DynamicTypes.Model.Pressreleases.PressReleaseBackendDefinition" module="ModuleBuilder" />
            
    Can you recall any changes to the module structure or backend definitions of the module?

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  6. Hooman
    Hooman avatar
    19 posts
    Registered:
    24 Jun 2016
    28 Jun
    Link to this post
    Ran into the same issue.  Seems like when adding content types/modules the data is not all in the database. Rather configuration files (as noted above) are also being changed in the project.  In our case we had a new deployment of the project which overwrote the previous config files...  I added the contentviewconfig.config entries that were missing.  That got me past the 500 error when the content types were being viewed in the application. however, the content list itself is empty despite the content appearing in the site itself.  Something else I am missing that got overwritten?
  7. Hooman
    Hooman avatar
    19 posts
    Registered:
    24 Jun 2016
    28 Jun
    Link to this post
    Update: we have a multi-site setup.  Something with dataprovider name in DynamicConfigManager.config seemed to be wrong.  The values had changed for my content types.  I reverted the values.  Then I had to go in each site and configure modules.  After selecting the module, I had to press change. There were 2 (!) entries listed for that site.  I unselected one and selected other.  after that I was able to see the content.
  8. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    08 Dec 2016
    01 Jul
    Link to this post
    Hello,

    The providers for the dynamic modules are listed in the configuration file. The relations between the providers and the sites are stored in the database - [sf_site_data_source_links].

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
8 posts, 0 answered