+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The enumeration value must be one of the following: None, Pages, Templates.

The enumeration value must be one of the following: None, Pages, Templates.

6 posts, 1 answered
  1. Ryan Dailey
    Ryan Dailey avatar
    41 posts
    Registered:
    08 Mar 2010
    18 Jul 2011
    Link to this post
    I am receiving this error whenever I try to open a page or a template in the administrator.  I just now started doing it all of a sudden.  I haven't really changed anything other than adding a new control to the toolbox.
  2. Ryan Dailey
    Ryan Dailey avatar
    41 posts
    Registered:
    08 Mar 2010
    20 Jul 2011
    Link to this post
    Does anyone have a solution to this?  I am still getting this error.  I am unable to use Sitefinity because of this.
  3. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    20 Jul 2011
    Link to this post
    Hello Ryan Dailey,

    Do you have a stack trace of the error or more detailed screenshot of where it occurs? I will need more information in order to diagonse the problem. Does the issue reference to the webconfig file?

    Best wishes,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  4. Ryan Dailey
    Ryan Dailey avatar
    41 posts
    Registered:
    08 Mar 2010
    20 Jul 2011
    Link to this post
    Okay.  I got it now.  It looks like I misspelled one of the values in the ToolboxesConfig.config.
  5. Colleen
    Colleen avatar
    10 posts
    Registered:
    04 Nov 2010
    16 Dec 2014
    Link to this post

    When I try to run my Sitefinity site locally under IIS (for the first time), I receive the error:

    The enumeration value must be one of the following: OnApplicationStart, OnFirstCall, Manual, Disabled.

    This website is running successfully in production.

    I run a various number of ASP.NET sites successfully under IIS, but this is the first Sitefinity site I am trying to setup under IIS.

    What could be the issue with my Sitefinity site under IIS? 

     

  6. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    18 Dec 2014
    Link to this post
    Hi all,

    @Coleen

    You have been given an answer in the support ticket. I will post it below for the rest of the community:
    "Can you please refer to the following forum post where the same issue has been discussed and checkout the suggestion there:


    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/bugs-issues/the-enumeration-value-must-be-one-of-the-following-none-pages-templates.aspx

    It seems that Sitefinity is not able to get a value from a config file. Unfortunately, the error message does not provide information about which is the config file.

    In addition to this, can you please check the documentation articles below and make sure that you have configured properly IIS to host Sitefinity projects:

    1. Configuring IIS to host Sitefinity projects
    2. Run projects on IIS
     
    In this article you can download and execute the PowerShell script (depending on the IIS version) in order to make sure that all the needed Windows features are turned on and IIS is configured properly to host Sitefinity projects.
    "


    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
6 posts, 1 answered