1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The 'namespace' attribute cannot be an empty string.

The 'namespace' attribute cannot be an empty string.

4 posts, 0 answered
  1. Paulo
    Paulo avatar
    21 posts
    Registered:
    06 Dec 2010
    07 Jun 2011
    Link to this post
    Hi

    I just upgrade my sitefinity site from 4.0 to the 4.1 and update all my custom controls and now I have a strange error:
    The 'namespace' attribute cannot be an empty string. (see attached image for error details)
    I don't know why is the namespace empty for the "SitefinityWebAp".

    PS:I have upgraded another site and averything goes fine. So why this one is not?

    Kind regards
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    09 Jun 2011
    Link to this post
    Hello Paulo,

    Please open the page and set some value to the namespace or remove this line.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Paulo
    Paulo avatar
    21 posts
    Registered:
    06 Dec 2010
    09 Jun 2011
    Link to this post
    Hi

    How can I do it?
    I don't have this page in the application, it is a page generated by sitefinity, and not a page that i have done. so I can't change it.

    How do sitefinity generates this page, and where did it go search the namespace to fill this attribute?
    The application is working fine in the previous version.

    Please help me on this.

    Looking to earing from you, best regards.
  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    18 Aug 2017
    10 Jun 2011
    Link to this post
    Hello Paulo,

    As discussed in the support ticket I modified the template and installed it and it ran successfully.
    Can you please consider placing the template under ~/App_Data/Sitefinity/WebsiteTemplates/YourTemplate/App_Master/yourtemplate.master as described in documentation. This way the template will not get modified by the upgrade procedure. When the template is in App_Master folder i will not need to Inherits="Sitefinity.Web.App" as if it was cretead in the root of the project. Also the tag prefixes you registered "ess, uss" were not available at my end so I removed them.
    The lines

    <%@ Register TagPrefix="uc" TagName="nav" Src="~/Modules/Navigation.ascx" %>

    <%@ Register TagPrefix="ess" Namespace="LanguageList" Assembly="LanguageList" %>

    are referencing not Sitefinity assembly and may provide error. Please test at your end where you have the whole project.

    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered