1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / The puzzle of Themes solved?

The puzzle of Themes solved?

5 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 May 2011
    Link to this post
    I just wondered if I am the one who has finally solved the puzzel why theme cause an error.

    I had everything set up fine in two themes

    ~/App_Themes/MyTemplate
    ~/App_Themes/MyTemplate_Wide

    And yes both hat the Global Folder

    This is what I had to do to make this work

    a) Stupid as I was I was under the impression I could give the front end theme in admin advanced a name like

    MyTemplate Wide (so I had a space in it) since I got an error I thought why not change the name to MyTemplateWide

    Still did not work

    b) So I changed the folder to ~/App_Themes/MyTemplateWide (removed the underscore)

    And voila it worked.

    I don't know if this is coincidentila with the amount of bytes at the moment in the RAM that are used in JAPAN, Switzerland and on my server or if this is another amazement of SF development.

    My advice at the moment

    Administration - Settings - FrontEnd Themes

    1) Dont use spaces in your Theme Name
    2) Dont use underscores in your Themes folder structure

    -----
    Looking forward to Teleriks testing if they can reproduce this issue or if its once again just me and my setup.

    Regard
    Markus
  2. Jordan
    Jordan avatar
    172 posts
    Registered:
    20 Oct 2015
    12 May 2011
    Link to this post
    Hello Markus,

    I have tested the scenario with a folder structure like the one described in the documentation:
    http://www.sitefinity.com/documentation/designers-guide/website-templates-file-structure.aspx

    In all of the following scenarios everything works great:

    Path: ~/App_Data/Sitefinity/WebsiteTemplates/Template/App_Themes/Theme 1
    Name: Theme 1

    Path: ~/App_Data/Sitefinity/WebsiteTemplates/Template/App_Themes/Theme_1
    Name: Theme_1

    Path: ~/App_Data/Sitefinity/WebsiteTemplates/Template/App_Themes/Theme1
    Name: Theme1



    All the best,
    Jordan
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    12 May 2011
    Link to this post
    Dear Jordan

    Thanks but .....

    I don't want a workaround every time. And yes I know this is what the documentation said.

    But isn't normal for once to have a standard .net structure and if SF behaves strange that you look into it.

    SF should be so 70% more efficient for developers but everything standard has to be done diffeently.

    /images can not be use
    /App_Themes  can not be used

    Do you care?

    Do you want to investigate what is happening when one uses App_Themes instead of /App_DAta/Sitefinity/WebsiteTemplasla........

    If not just tell me and I stop reporting strange stuff happening (even though I am not following the exact instructions on the documentation.

    Markus

    Back to my car anology.

    Customer: The breaks on my Chevy don't work properly
    Telerik: We tested the breaks on our Ford - everything works properly

    In other words - Get a Ford!
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    12 May 2011
    Link to this post
    Hi Markus,

    I don't want a workaround every time. And yes I know this is what the documentation said.

    This is not a workaround, but what is currently supported. I saw your point of having both things supported - the traditional way and our way, and also expressed an opinion why this is so at the moment :) As usual, the feedback is appreciated and we always keep it in mind (which reminds me about the huge discussion today, here at the office about the 4-eye workflow, but this is another topic).

    /images will be different after SP2, but we also going to publish a solution with SP1 on how to use it without any mofications, just configuration change.

    Best wishes,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    12 May 2011
    Link to this post
    Dear Georgi

    Thanks for the feedback.

    It simply would have been nice if anyone from Telerik would have tested my scenario and if this problem realy exists would have said.

    a) We can not reproduce it
    or
    b) We can reproduce it - Thanks for telling us and we will look into it.

    I don't mind having to do some stuff the SF way. But if you are not a programmer and want to use SF as much as possible things must be kept simple. And at the moment the 70 % increase in productivity is only for those programming. For anybody else every thing takes longer then on 3.7 (This might also because there are so many huge bugs that you often wonder what you do wrong only to find out later - Search is not working, custom roles not supported and stuff.)

    If indead a simple _ in a theme name would cause a problem (when in ~/App_Themes)  this should be fixable easely. After all if it works without an _ then you would expect it to work with the _ as well. its not like I used a special character.

    But then again the case might not even be true and it a whole different problem on my side.

    But I know how time comsuming testing is. I do a lot with SF (look at my points) and of I understand that  you are under pressure and testing everything we report (80% probably our fault) takes a lot of time.

    Markus

    PS: Glad the 4-eyes workflow is at least discussed about. If you need any argument I more then willing to explain to anyone a Telerik who sees it differntly that an 4-eye workflow somehow seems a basic requirement.
5 posts, 0 answered