1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Theme Stylesheet being cut off

Theme Stylesheet being cut off

3 posts, 0 answered
  1. Rick
    Rick avatar
    7 posts
    Registered:
    23 Jul 2012
    24 Apr 2012
    Link to this post
    I have created a theme with a style sheet in the correct location (~\App_Themes\Base\Global) Base being the name of the theme.  From the start up of sitefinity everything will work correctly and all of the css will load.  As I start to make changes the to css file, reload the page, repeat, there is a point where the css file will become cut-off.  Meaning if started with 200 lines in the css and I added 5 more (totaling 205 lines), the browser seems to only receive the first 200 line still, causing the css rules at the end to be truncated.  Keep in mind the numbers are just to illustrate the issue, I haven't actually confirmed the cutoff is that specific.  The only way i've found to resolve it is to restart sitefinity (running in instance mode).

    I did disable the Output Cache under settings.

    Is there another cache setting I am missing?  Is there another way to flush the cache?  Something else I might be missing?

    Thanks
    -Rick

    P.S. I am using Firefox 11 with the cache disabled.
  2. Jen Peleva
    Jen Peleva avatar
    568 posts
    Registered:
    10 Nov 2016
    27 Apr 2012
    Link to this post
    Hi Rick,

    Does this behaviour reproduce in all browsers? So far a similar issue has been reported once, but only in Firefox. Is it possible that it is related to your browser's cache?

    Kind regards,
    Jen Peleva
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rick
    Rick avatar
    7 posts
    Registered:
    23 Jul 2012
    27 Apr 2012
    Link to this post
    Hi Jen,

    I've been doing some more testing with firefox and chrome.  It actually may be specific to FF.  Trying to load a page in FF after a change in the css seems to display the old css, but loading the same page in chrome displays the correct css.  Interestingly enough, then reloading the page in FF produces the refreshed page.

    Thanks
    -Rick
3 posts, 0 answered