+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / There was no endpoint listening at Pages Approval Workflow in Sitefinity 6.2

There was no endpoint listening at Pages Approval Workflow in Sitefinity 6.2

5 posts, 0 answered
  1. Krishnamorrthy
    Krishnamorrthy avatar
    10 posts
    Registered:
    20 Jun 2013
    22 May 2014
    Link to this post

    I upgraded Sitefinity version 3.7 to 6.2, then published the page using ISA server with my Public IP (e.g 123.456.00.25). I can access the site through the internet but when I tried to edit and publish the page, it shows error "There was no endpoint listening at 'http://123.456.00.25/defaultWorkflows/PagesApprovalWorkflow.xamlx that could accept the message. This is often caused by an incorrect address or SOAP action." Please check the attached ScreenShot.We tried the below link " http://www.sitefinity.com/developer-network/knowledge-base/pages-cannot-be-published-after-installation" but not working. Please help to fix this .thanks in advance.

  2. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    23 May 2014
    Link to this post
    Hello Krishnamorrthy,

    The information in the link is viable. Changing the WorkflowBaseUrl should eliminate the issue. Did you remember to restart the application after the changes were made? A restart is needed in order for the configuration changes to take effect.

    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Krishnamorrthy
    Krishnamorrthy avatar
    10 posts
    Registered:
    20 Jun 2013
    26 May 2014 in reply to Ivan D. Dimitrov
    Link to this post

    Hi,

     This error solved by Host entry...  I done the entry in hosts file as

    192.168.0.155  mydomain.com

    Here 192.168.0.155 is Local IP for the Machine 

  4. Adele
    Adele avatar
    1 posts
    Registered:
    11 Nov 2015
    11 Nov 2015
    Link to this post
    I am also troubleshooting this issue for SiteFinity version 6.1.  There is no URL located in the WorkflowBaseUrl setting.  
  5. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    09 Dec 2016
    28 Dec 2015
    Link to this post
    Hi Adele,

    Can you please try to set the WorkflowBaseURL setting to the domain name? Then please make sure that the hosts file of your server has an entry binding your localhost IP to the domain that is used in the bindings section of IIS. After that please restart the application and open the project to test the behvaior. 

    After setting the WorkflowBaseUrl and configuring the hosts files the publishing of pages should work properly.

    Please also refer to the below KB article for more details about this:
    http://www.sitefinity.com/developer-network/knowledge-base/details/pages-cannot-be-published-after-installation

    Regards,
    Sabrie Nedzhip
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
5 posts, 0 answered