+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Type is enhanced and registered, but not avaiable from the database clas meta data

Type is enhanced and registered, but not avaiable from the database clas meta data

6 posts, 0 answered
  1. Omar
    Omar avatar
    8 posts
    Registered:
    24 Dec 2013
    16 Oct 2014
    Link to this post
    Sometimes when entering the ecommerce / Sitefinity orders within me generates this error. it may be happening?
  2. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    21 Oct 2014
    Link to this post
    Hi Omar,

    Thank you for contacting us.

    We have been having similar reports before, but we were not able to reproduce the problem. Can you recall when the issue started occurring? Were there any changes made to the products or the workflows? Please check  Administration -> Settings -> Advanced -> Workflow -> Providers for any custom configurations. 

    So far we have established that this error manifests itself when you have two contexts to one database and using one and the same data object simultaneously, including cashed connection. This should be solved by disposing the managers. 

    var manager = AnyManager.GetManager();
      
    //some logic with the manager here
      
    manager.Dispose();

    Similar problem is discussed here and here. Do you have any custom module that uses database connection which could be causing the issue? In such case try disposing of the managers, or try applying the solution with 2 connection strings as suggested in one of the referred threads. 

    Also I found the following bug in our system (fixed in 7.2 5300):

    http://feedback.telerik.com/Project/153/Feedback/Details/136225-exception-on-first-load-when-using-relateddata-product-product

    Can you please confirm your Sitefinity version stated in the ticket info (7.2 5310)? To do so please go to Administration->Version & Licensing and check there. 

    You can try a local test upgrade to latest internal build as well to see if this resolves the issue. 

    If problems persist would it be possible for you to provide me with a bit more details on your setup with Ecommerce - product types, custom fields etc. as well as backend access to the project so I can examine some of the configurations.

    I hope this helps. Looking forwards to your observations.


    Regards,
    Pavel Benov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Praneeth
    Praneeth avatar
    26 posts
    Registered:
    22 Jun 2012
    29 Apr 2015
    Link to this post

    We are also getting the same issue in Sitefinity 7.2. The way to reproduce this is

     Step 1. ) Navigate to Administration->Settings->Advanced->Data->set Enable Data Caching to false

    Step 2 .) IISReset

     Step 3.) Navigate to any ecommerce front end pages which will be calling any manager like var mgr = Catalogmanager.GetManager(); mgr.GetProducts().FirstOrDefault();

     Step 4.) Ideally the exception can occur here. If not then repeat Step 1 and set Enable Data Caching to empty value.

     Step 5.) IISReset

     By now you should get the error most likely in the index page itself or the page where you are calling the instance of the CatalogManger.

     

    Hope this helps.

     

    Thanks

    Praneeth

  4. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    09 Sep 2016
    04 May 2015
    Link to this post
    Hi,

    Thank you for the steps provided. Indeed the bug was reopened and then fixed as you can see in our comments in the Feedback portal:

    http://feedback.telerik.com/Project/153/Feedback/Details/136225-exception-on-first-load-when-using-relateddata-product-product

    The fix has been included in 7.3.5614.0 internal build. You can check our release notes:

    http://www.sitefinity.com/developer-network/forums/internal-builds/sitefinity-7.3-internal-builds

    Excuse us for the inconvenience caused.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Praneeth
    Praneeth avatar
    26 posts
    Registered:
    22 Jun 2012
    04 May 2015 in reply to Stefani Tacheva
    Link to this post
    Thanks for the confirmation Stefani. This helps. As I am in midst of moving to production is there any quick fix for 7.2 itself?
  6. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    09 Sep 2016
    04 May 2015
    Link to this post
    Hello,

    I am afraid that there are no workarounds available for this problem, an upgrade should be performed. More information for the upgrade procedure can be found in our Upgrade documentation article:

    http://docs.sitefinity.com/upgrade​


    You need to upgrade to latest internal build of Sitefinity 7.3 version or to our latest major one Sitefinity 8.0.

    Latest internal builds are available in your account in section Products & Subscriptions -> Latest Internal Builds.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
6 posts, 0 answered