1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Unable to send mail via SMPT

Unable to send mail via SMPT

5 posts, 0 answered
  1. Jonathan Withers
    Jonathan Withers avatar
    2 posts
    Registered:
    26 Jul 2012
    26 Oct 2011
    Link to this post
    I am new to SiteFinity and have just configured our site to send SMPT emails for forgotten passwords.

    I have set the SMPT details on the administration screen however on the login page when i click the forgotten password link i get the error below. I am unsure how to resolve this.

    The system is denied the permission(s) to send email.

    • Contact an administrator to reset your password manually.
    • Or, ask an administrator to configure the system. Details

    The system has not been configured to send emails. Go to SMTP settings or ask your administrator to set them

  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    28 Oct 2011
    Link to this post
    Hello Jonathan Withers,

    First of all you need to have a set host. You need to check if your settings are correct - if you use a different SMTP port (other than 25) try and see that you can actually have permissions to connect to this server on this port.

    Regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ron
    Ron avatar
    3 posts
    Registered:
    28 Sep 2010
    31 Oct 2011
    Link to this post
    I am actually having the same issue. I setup the SMTP settings and still get the "The system has not been configured to send emails" message when you click Forgot Password. I have confirmed that the settings work properly by using the same settings as the Email Campaigns. I receive emails when clicking the Send Test Message button on that screen.

    The SMTP server doesn't require a login, but even when I set it, it still fails. I'm currently running version 4.2.
  4. Jonathan Withers
    Jonathan Withers avatar
    2 posts
    Registered:
    26 Jul 2012
    31 Oct 2011
    Link to this post
    Ron,

    I managed to solve the issue with the help of a user error!
    I think the resolution of the problem for me was :-
    1. stopping the application pool within IIS
    2. Removing the temporty asp.net files from the system
    3. Starting the application pool again. 
  5. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    01 Nov 2011
    Link to this post
    Hello Ron,

    In order for the forgot password form to be working correctly you need to set the following values in your membership provider:

    recoveryMailAddress
    recoveryMailBody

    Also, for recoveryMailBody you need to use the following special tags somewhere in the mail body:

    <%\s*UserName\s*%>
    <%\s*Password\s*%>

    Otherwise the system won't be able to send proper emails.

    Greetings,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered