+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Updating Pages Error - Row not found: GenericOID@

Updating Pages Error - Row not found: GenericOID@

58 posts, 0 answered
  1. Christine
    Christine avatar
    31 posts
    Registered:
    25 Jan 2008
    28 Sep 2011
    Link to this post
    I am noticing this error quite a bit on a 4.2 site that is (hardware) load balanced and has the sitefinity data caching disabled.  Is this "officially" a bug or are there some Sitefinity settings (or OpenAccessORM settings) that should be tweaked?

    I do notice that if I only utilize a single server, I very rarely encounter this issue.
  2. Jason
    Jason avatar
    3 posts
    Registered:
    04 May 2011
    29 Sep 2011
    Link to this post
    Hi,

    Any updates here?  We started getting this problem immediatly after adding more worker processes, which we needed to do to handle server load. 

    Thanks,
    Jason
  3. Joel
    Joel avatar
    40 posts
    Registered:
    30 Nov 2010
    30 Sep 2011
    Link to this post
    Hey Jason, A couple of posts below, the Telerik guys confirmed my fears and said 4.2 wasn't supporting web gardens yet. Guys, please correct me if I'm wrong. Joel
  4. Jason
    Jason avatar
    3 posts
    Registered:
    04 May 2011
    30 Sep 2011
    Link to this post
    I was thinking about making the /sitefinity folder it's own app pool with a single worker process and have the main root folder be another app pool with multiple processes. What do you think?
  5. Joel
    Joel avatar
    40 posts
    Registered:
    30 Nov 2010
    30 Sep 2011
    Link to this post
    Yeah, we tried running a separate instance of IIS for our content editor to do her work in. No dice.

    I'm not saying that we tried what you're suggesting, I'd be curious to hear your results!

    Joel
  6. Jason
    Jason avatar
    3 posts
    Registered:
    04 May 2011
    30 Sep 2011
    Link to this post
    Hey Joel,

    Is there a way we can chat over an instant messenger client and/or e-mail?  I'd like to talk with you a bit more about this issue if you're open to it.

    Thanks,
    Jason
  7. Joel
    Joel avatar
    40 posts
    Registered:
    30 Nov 2010
    30 Sep 2011
    Link to this post
    Yeah, you can hit me up- don't know what kind of help I can be, but I'll certainly try.

    jmusheno@ohio-cpa.com
  8. Volkan Demirpençe
    Volkan Demirpençe avatar
    1 posts
    Registered:
    15 Sep 2011
    14 Oct 2011
    Link to this post

    I  tried to create page programmatically. After some attempt to create and delete some content, i couldn't open page templates.
    I added a dummy record to "sf_page_node" table.  Dummy record content_id is the guid that shown at error message. I know it's not a good solution, but it's ok now.
  9. Jacob
    Jacob avatar
    5 posts
    Registered:
    20 Oct 2011
    02 Nov 2011
    Link to this post
    It is now Novmber 2nd, and we are having this same issue.

    Row not found: GenericOID@137e53a5 Blog content_id=4b0b121c-c375-416b-8ec6-9b5caf6c2333
    UPDATE [sf_blogs] SET [last_modified]=?, [voa_version]=? WHERE [content_id] = ? AND [voa_version]=?
    (set event logging to all to see parameter values)

    For also sometimes get locked out of the form manager, and right now we are unable to change the templates that pages are assigned to, and instead get the following error:

    Object reference not set to an instance of an object.


    Is there still no resolution to this problem?? We have also submitted a ticket that seems to be going no where with Lubomir.
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    04 Nov 2011
    Link to this post
    Hello Jacob,

    There is a know issue in the release notes about "row not found error"

    Known Issues
     

    • Pages, Content: When a content is locked for editing by a user, other users get error “Row not found…” upon accessing it"
    You can try to disable the second level caching of Open Access ( take a look at attached screenshot)which seems to be a workaround in some of the cases. Also make sure that you are not having some custom triggers set for the database.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Erik
    Erik avatar
    62 posts
    Registered:
    02 May 2011
    04 Oct 2012
    Link to this post
    Has there been any resolution to this? I am running Sitefinity 5.0.2523.0 SE. The entire production site can't publish content and gets this error each time we try.
  12. Erik
    Erik avatar
    62 posts
    Registered:
    02 May 2011
    04 Oct 2012
    Link to this post
    Has there been any resolution to this? I am running Sitefinity 5.0.2523.0 SE. The entire production site can't publish content and gets this error each time we try.
  13. Erik
    Erik avatar
    62 posts
    Registered:
    02 May 2011
    04 Oct 2012
    Link to this post
    I just followed this solution (http://community.dynamics.com/product/crm/crmtechnical/b/magnetism/archive/2012/04/19/preventing-row-not-found-error-in-sitefinity-on-windows-azure.aspx) which involves disabling the OpenAccess Level 2 cache. That kind of sucks as a solution but it seems to make everything work.
  14. Josep
    Josep avatar
    8 posts
    Registered:
    07 Jun 2012
    23 Aug 2013 in reply to Erik
    Link to this post
    Hi, The link does not works, do you have the steps do I need to do?
  15. Josep
    Josep avatar
    8 posts
    Registered:
    07 Jun 2012
    23 Aug 2013
    Link to this post
    After 2 years there is no a public information or official solution to this issue? We are on SF 5.2 and still the same problem.
  16. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    28 Aug 2013
    Link to this post
    Hi,

    I would like to suggest upgrading to at least version 5.4:Upgrade. In the meantime, you can disable level 2 cache from here: Administration - Settings - Advanced - Data, set it to False, save and restart:http://screencast.com/t/wzStSQTIYthj

    I hope this helps.

    Regards,
    Atanas Valchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Kent
    Kent avatar
    5 posts
    Registered:
    05 Jul 2011
    27 Sep 2013 in reply to Atanas Valchev
    Link to this post
    FYI, we are on Sitefinity 5.4.4010, and the problem still exists.  Disabling the second-level caching and restarting does appear to resolve some of the issues, but this cannot (and should not) be a long-term fix.  And please don't suggest upgrading to 6.x.  My clients are skittish enough about Sitefinity as it is...

    Kent
  18. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    02 Oct 2013
    Link to this post
    Hi,

    The issue has been resolved in the latest version, that is why, I would like to suggest upgrading.

    Regards,
    Atanas Valchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  19. vinod
    vinod avatar
    3 posts
    Registered:
    24 Jul 2013
    27 Nov 2013
    Link to this post
    I am facing this issue in Sitefinity 5.3. this occurs when I Edit and publish the pages. Attached the error screen.
  20. IT
    IT avatar
    1 posts
    Registered:
    20 Mar 2014
    24 Mar 2014
    Link to this post

    We are on Sitefinity 6.1, and this error is occurring for our users when they save a page. Is there anything you can suggest in terms of alleviating this message?

    Hi,The issue has been resolved in the latest version, that is why, I would like to suggest upgrading.Regards,
    Atanas Valchev 
    Telerik

     

  21. Allen
    Allen avatar
    3 posts
    Registered:
    18 Dec 2012
    02 Apr 2014 in reply to IT
    Link to this post

    FYI everyone that has this error... I am on SF 6.3 and I just encountered the error... Does anyone have a better solution other than disabling the L2 cache?

  22. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    04 Apr 2014
    Link to this post
    Hello,

    There are cases where this could be caused by something else than the L2 cache. It would be helpful if you could share the stack trace. Are you able to reliably reproduce it?

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  23. Corby
    Corby avatar
    48 posts
    Registered:
    19 Sep 2011
    12 May 2015 in reply to Atanas Valchev
    Link to this post

    7.0.5100, May 2015, this issue still exists.  I am unable to edit pages in our production environment.  Yes, caching already set to "False".  Recycled app pool, restarted website, turned off website/recycled app pool/turned website back on....same error.

    Deleted the offending page from Stage, "Notres", synced it as deleted to production...no help.  Searched for offending page in production's Pages view, found it (even though it had been deleted in stage and synced) and deleted it from production via unpublish/delete...same problem.

     

    Server Error in '/' Application.

    No row for Telerik.Sitefinity.Pages.Model.PageNode ('sf_page_node') GenericOID@88d17800 PageNode id=bed88c77-98cf-6a15-a1a9-ff0b00d30354 NOTRESDescription: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: Telerik.OpenAccess.Exceptions.NoSuchObjectException: No row for Telerik.Sitefinity.Pages.Model.PageNode ('sf_page_node') GenericOID@88d17800 PageNode id=bed88c77-98cf-6a15-a1a9-ff0b00d30354 NOTRES 

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace: 

    [NoSuchObjectException: No row for Telerik.Sitefinity.Pages.Model.PageNode ('sf_page_node') GenericOID@88d17800 PageNode id=bed88c77-98cf-6a15-a1a9-ff0b00d30354 NOTRES ] OpenAccessRuntime.ExceptionWrapper.Throw() +13 OpenAccessRuntime.DataObjects.PCStateMan.handleException(Exception x) +101 OpenAccessRuntime.DataObjects.PCStateMan.getObjectFieldImp(PersistenceCapable pc, FieldMetaData fmd, Object currentValue) +183 Telerik.Sitefinity.Pages.Model.PageNode.get_Parent() +82 Telerik.Sitefinity.Web.PageSiteNode..ctor(SiteMapBase provider, PageNode pageNode, String pageProviderName) +574 Telerik.Sitefinity.Web.SiteMapBase.FindSiteMapNodeFromKey(String key, Boolean ifAccessible) +944 Telerik.Sitefinity.Modules.GenericContent.DynamicLinksParser.GetContentUrl(String key, Guid id, Boolean resolveAsAbsoluteUrl, ContentLifecycleStatus status) +1772 Telerik.Sitefinity.Web.Utilities.LinkParser.Resolve(HtmlChunk chunk, Int32 valueIndex, GetItemUrl itemUrl, ResolveUrl resolveUrl, Boolean preserveOriginalValue, Boolean resolveAbsolute) +995 Telerik.Sitefinity.Web.Utilities.LinkParser.ParseHtml(String html, GetItemUrl itemUrl, ResolveUrl resolveUrl, Boolean resolve, Boolean preserveOriginalValue, Boolean resolveAbsolute, ProcessChunk processChunk) +851 Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlockBase.InitializeControls(GenericContainer container) +151 Telerik.Sitefinity.Modules.GenericContent.Web.UI.ContentBlock.InitializeControls(GenericContainer container) +433 Telerik.Sitefinity.Web.UI.SimpleView.CreateChildControls() +88 System.Web.UI.Control.EnsureChildControls() +189 System.Web.UI.Control.PreRenderRecursiveInternal() +60 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4297

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34212​

  24. Michelle
    Michelle avatar
    9 posts
    Registered:
    17 Apr 2014
    27 May 2015 in reply to Corby
    Link to this post
    It is May 27th, 215 and I have this error. Using Sitefinity 7.3... this question was originally for 4.0. Why the hell is there not a fix??
  25. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    01 Jun 2015
    Link to this post
    Hello,

    This particular error occurs when the page node with the specified id cannot be found and is not related to the Level 2 caching. Please, open a ticket for your specific issue and we will be able to investigate further and request a copy of the project if needed.

    Regards,
    Atanas Valchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  26. Jeremy
    Jeremy avatar
    10 posts
    Registered:
    13 May 2015
    09 Jun 2015 in reply to Stephen
    Link to this post

    Reseting IIS solves more than just this bug. I am finding myself having to more frequently end IIS in task manager, but also resetting IIS on our production server. Resetting IIS resets sitefinity, so if you want to see your changes, you have to end the task in ur dev env, or on whatever IIS server that you're using. Also, doing a reset of IIS just solved the problem of content being changed on a page in the dashboard wasn't being seen on the actual  website.

     LISDFJK,

    Jeremy

  27. Michelle
    Michelle avatar
    9 posts
    Registered:
    17 Apr 2014
    16 Jun 2015 in reply to Atanas Valchev
    Link to this post
    To be honest, I posted this a while ago and don't remember why this error was coming up. Probably had to find some workaround again because you guys have been MIA for the last 8 months. Welcome back Telerik, glad to see your forums are fixed, but these responses 5+ months later are pretty useless when companies are trying to launch websites using your CMS every day.
  28. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    06 Dec 2016
    17 Jun 2015
    Link to this post
    Hi,

    We aim to give a chance to the community members to assist and provide useful suggestions. This is the reason why we do not always provide replies in the forum threads. Moreover, I would like to inform you that we update existing forms when we have further information on specific requirement, question or problem discussed.

    Have in mind that you can take advantage of the other support or premium services listed here.

    Regards,
    Stefani Tacheva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
58 posts, 0 answered
1 2