+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Uploading files - Error - Response message does not match

Uploading files - Error - Response message does not match

4 posts, 1 answered
  1. Gerrit
    Gerrit avatar
    30 posts
    Registered:
    28 Jul 2010
    14 Oct 2014
    Link to this post
    Hi We get a very strange error when uploading any documents/images to our site. We are on Sitefinity 6.0.I've attached our error message, can someone please help? I do not know if this is the reason, this site where this occurs is on a sub-domain. The www domain is on Sitefinity 6.3, so not sure if this might be the issue? I've highlighted in the error message that it looks like it wants to do something on the www site, not sure why?

    Kind Regards
    Gerrit
  2. Gerrit
    Gerrit avatar
    30 posts
    Registered:
    28 Jul 2010
    14 Oct 2014 in reply to Gerrit
    Link to this post

    UPDATE:

    I've checked, we've got another sub-domain and the site is on Sitefinity 6.1 and it can upload files, so I do not think its the reason for this.

     Kind Regards

  3. Gerrit
    Gerrit avatar
    30 posts
    Registered:
    28 Jul 2010
    14 Oct 2014 in reply to Gerrit
    Link to this post

    UPDATE:

     Found on the server the following in the event-logs, can someone shed some light on this?

    Log Name:      Application
    Source:        ASP.NET 4.0.30319.0
    Date:          2014/10/14 03:32:28 PM
    Event ID:      1309
    Task Category: Web Event
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      war01-win6.wadns.net
    Description:
    Event code: 3012 
    Event message: An error occurred processing a web or script resource request. The resource identifier failed to decrypt. 
    Event time: 10/14/2014 3:32:28 PM 
    Event time (UTC): 10/14/2014 1:32:28 PM 
    Event ID: 5f525eed5a23440984cf1d9588d114d9 
    Event sequence: 75 
    Event occurrence: 22 
    Event detail code: 0 
     
    Application information: 
        Application domain: /LM/W3SVC/20/ROOT-6-130577663078024791 
        Trust level: Full 
        Application Virtual Path: / 
        Application Path: XXXX 
        Machine name: WAR01-WIN6 
     
    Process information: 
        Process ID: 20348 
        Process name: w3wp.exe 
        Account name: XXXX 
     
    Exception information: 
        Exception type: HttpException 
        Exception message: Unable to validate data.
       at System.Web.Configuration.MachineKeySection.EncryptOrDecryptData(Boolean fEncrypt, Byte[] buf, Byte[] modifier, Int32 start, Int32 length, Boolean useValidationSymAlgo, Boolean useLegacyMode, IVType ivType, Boolean signData)
       at System.Web.UI.Page.DecryptString(String s, Purpose purpose)
       at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)

     
     
    Request information: 
        Request URL: XXXX/WebResource.axd?d=2mtss0xQ_-YC8L1Wz8h-g3wfMz6zLFRssJr01xKJ3jwZROBf12nW-Uz440X4-EUy0k95cnNhMSMnvn5X-9Fjuc7czL-iREYzvWmnTqW4-yz8bVs5JPb24nBobm2DvGBF7405osYnQ1YBTjKltkX8QIh8RJGQn-Vdrf61jtcXcavOh5bZ_dS_Hwhuz1PU8BSUfLyZwWxWu4zRu0SG-r2qWA2&t=635119021133098734 
        Request path: /WebResource.axd 
        User host address: 41.161.59.218 
        User: warpadmin 
        Is authenticated: True 
        Authentication Type: Sitefinity 
        Thread account name: XXXX 
     
    Thread information: 
        Thread ID: 51 
        Thread account name: XXX 
        Is impersonating: False 
        Stack trace:    at System.Web.Configuration.MachineKeySection.EncryptOrDecryptData(Boolean fEncrypt, Byte[] buf, Byte[] modifier, Int32 start, Int32 length, Boolean useValidationSymAlgo, Boolean useLegacyMode, IVType ivType, Boolean signData)
       at System.Web.UI.Page.DecryptString(String s, Purpose purpose)
       at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)
     
     
    Custom event details: 

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ASP.NET 4.0.30319.0" />
        <EventID Qualifiers="32768">1309</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2014-10-14T13:32:28.000000000Z" />
        <EventRecordID>913242</EventRecordID>
        <Channel>Application</Channel>
        <Computer>war01-win6.wadns.net</Computer>
        <Security />
      </System>
      <EventData>
        <Data>3012</Data>
        <Data>An error occurred processing a web or script resource request. The resource identifier failed to decrypt.</Data>
        <Data>10/14/2014 3:32:28 PM</Data>
        <Data>10/14/2014 1:32:28 PM</Data>
        <Data>5f525eed5a23440984cf1d9588d114d9</Data>
        <Data>75</Data>
        <Data>22</Data>
        <Data>0</Data>
        <Data>/LM/W3SVC/20/ROOT-6-130577663078024791</Data>
        <Data>Full</Data>
        <Data>/</Data>
        <Data>XXXX</Data>
        <Data>WAR01-WIN6</Data>
        <Data>
        </Data>
        <Data>20348</Data>
        <Data>w3wp.exe</Data>
        <Data>XXX</Data>
        <Data>HttpException</Data>
        <Data>Unable to validate data.
       at System.Web.Configuration.MachineKeySection.EncryptOrDecryptData(Boolean fEncrypt, Byte[] buf, Byte[] modifier, Int32 start, Int32 length, Boolean useValidationSymAlgo, Boolean useLegacyMode, IVType ivType, Boolean signData)
       at System.Web.UI.Page.DecryptString(String s, Purpose purpose)
       at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)

    </Data>
        <Data>https://corporate-online.medihelp.co.za:443/WebResource.axd?d=2mtss0xQ_-YC8L1Wz8h-g3wfMz6zLFRssJr01xKJ3jwZROBf12nW-Uz440X4-EUy0k95cnNhMSMnvn5X-9Fjuc7czL-iREYzvWmnTqW4-yz8bVs5JPb24nBobm2DvGBF7405osYnQ1YBTjKltkX8QIh8RJGQn-Vdrf61jtcXcavOh5bZ_dS_Hwhuz1PU8BSUfLyZwWxWu4zRu0SG-r2qWA2&amp;t=635119021133098734</Data>
        <Data>/WebResource.axd</Data>
        <Data>XXX</Data>
        <Data>warpadmin</Data>
        <Data>True</Data>
        <Data>Sitefinity</Data>
        <Data>XXX</Data>
        <Data>51</Data>
        <Data>XXX</Data>
        <Data>False</Data>
        <Data>   at System.Web.Configuration.MachineKeySection.EncryptOrDecryptData(Boolean fEncrypt, Byte[] buf, Byte[] modifier, Int32 start, Int32 length, Boolean useValidationSymAlgo, Boolean useLegacyMode, IVType ivType, Boolean signData)
       at System.Web.UI.Page.DecryptString(String s, Purpose purpose)
       at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)
    </Data>
      </EventData>
    </Event>

  4. Gerrit
    Gerrit avatar
    30 posts
    Registered:
    28 Jul 2010
    15 Oct 2014 in reply to Gerrit
    Link to this post

    Hi

     I found the problem, it was a problem with the binding in IIS, and our SSL certificate. This is sorted.

     Kind Regards

    Answered
4 posts, 1 answered