+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Widget does not show when not logged in

Widget does not show when not logged in

4 posts, 0 answered
  1. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    12 Mar 2015
    Link to this post

    Hi,

    I created a widget that loads some dynamic data. When I'm not logged in into the backend, the widget doesn't show.

    I've checked the permissions for the widget itself and also permissions for the Dynamic Content Items. All View permissions are set to Everyone, so that should do the trick.

    What else can be wrong?

    Best,
    Daniel

  2. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    17 Mar 2015
    Link to this post
    Hello,

    The problem may be that when not logged in the Sitefinity API for Dynamic modules may not be executing at all, you can check in debug if the API calls gets executed and return any data. This non execution is caused by a requirement that the API is executed only for authenticated users and to bypass authentication requirements wrap the code that uses Sitefinity API in
    ElevatedModeRegion
    a sample is available here.

    Regards,
    Stanislav Velikov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    17 Mar 2015 in reply to Stanislav Velikov
    Link to this post

    Hi Stanislav,

    This was also an issue with the built-in widget for the Dynamic Module. I applied this fix: http://www.sitefinity.com/developer-network/knowledge-base/unable-to-access-dynamic-items-permissions-section-after-an-upgrade-to-sitefinity-7.3

    And it worked for one Dynamic Module. The other one is now fixed after upgrading to 8.0.

    Best,
    Daniel

  4. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    17 Mar 2015
    Link to this post
    Hello Daniel,

    The problem that the KB article address is for not correctly applying permissions for users other that users in role Administrators with this I assume the use of ElevatedModeRegion wrapping the code of the custom widgets now gives results and the widgets work when a non authenticated user view a page witht he widgets.

    If there is still a problem persisting please let me know.

    Regards,
    Stanislav Velikov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
4 posts, 0 answered