+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / "Workflow could not be activated" error message

"Workflow could not be activated" error message

7 posts, 0 answered
  1. Jon
    Jon avatar
    4 posts
    Registered:
    11 Jul 2011
    21 Jun 2012
    Link to this post
    Hello, my company has several sites that are using Sitefinity. Our latest addition was just deployed the other day. The new site functions fine from the front end, but if a user is logged into the back end to add/edit content, we are constantly getting an error message about workflows not being able to be activated. The exact error message is:
     "The requested service, 'http://domainname.com/DefaultWorkflows/PagesApprovalWorkflow.xamlx', could not be activated. See the server's diagnostic trace logs for more information."

    In looking through the forums I have seen this issue before and the suggested solution was to edit the WorkflowBaseUrl setting within Administration > Settings > Advanced > System > Service Paths. However, I have changed that setting from blank to our domain name (which would be the proper base url) and I was still getting that error message. I had also read in the forum to try the local loopback IP address, (127.0.0.1) and that caused a different error message stating:

    "There was no endpoint listening at http://website/Workflows/PagesApprovalWorkflow.xamlx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details."
     

    I had also seen in the same forum post that some users have had to do a combination of editing the host file to point to itself (so the host file points the website domain name to itself) and changing the WorkflowBaseUrl setting, but this suggestion has not worked either.

    This site is Sitefinity 5.0 website running in IIS 7.5 that has been upgraded from Sitefinity 4.1. And the strange thing about this is that the site will function fine locally. I need to find some solution for this problem. Any suggestions would be greatly appreciated. 
  2. catoegroup
    catoegroup avatar
    21 posts
    Registered:
    23 Apr 2010
    27 Jul 2012
    Link to this post
    Any fix figured out?
  3. Nick Pearce
    Nick Pearce avatar
    8 posts
    Registered:
    22 Apr 2008
    07 Nov 2012
    Link to this post
    I'm also trying to resolve this.
  4. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    12 Nov 2012
    Link to this post
    Hi Jon,

    The problems that you have been experiencing are most likely related to the server environment, on which the project is hosted. The WorkflowBaseURL property is indeed required, but it may not resolve the issues with the endpoint error, if the environment is more complicated or there are some redirections / applied to the website /server, which are misleading the workflow.

    If possible, please provide screenshots of the following files, so we can understand what is happening on your end:

    - server's hosts file
    - IIS site bindings

    Any additional information about the server setup and environment would be helpful.

    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Rich
    Rich avatar
    3 posts
    Registered:
    01 Aug 2012
    19 Dec 2012 in reply to Jon
    Link to this post
    I am wondering if there has been any resolve yet on this issue. We have installed the QA system in one of our Rackspace environments. If we are logged into the VM with edits then everything is fine however, when we try to access the Backend area and try to edit, save or modify pages we get the error message. We have not moved our domain site yet because we are still in the migration process and accessing the site through the bound ip address. This is a pretty urgent issue because we cannot have our content people work on the system without setting them up on VPN and ect. The VM box is Windows 2008 r2 server with IIS 7.5.

    PS.. I have tries some of the settings mentioned above and did not see them referenced I am running Sitefinity 5.2.3800.0. Also as an added comment I am logged in as an Admin user
  6. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    21 Dec 2012
    Link to this post
    Hi Rich,

    The error that is discussed in most cases is related to the specific environment on which the project is hosted. Basically you might need to set the WorkflowBaseURL to your site your site URL to make sure that the system can find the paths to the workflows. Also, please consider reviewing the following article as it contains specific instructions and settings that need to be set on your new machine:

    http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/install-sitefinity/configuring-the-iis-to-host-sitefinity-projects


    If you wish you can send us details and screenshots about your environment through the ticket support channel as well.

    Greetings,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Rich
    Rich avatar
    3 posts
    Registered:
    01 Aug 2012
    21 Dec 2012 in reply to Victor Velev
    Link to this post
    Thank you for the response, the support team helped my out we found the issue. We are using Rackspace as a hosting provider on some Virtual machines. The Machines were using an Internal IP address 170.20.x.x and the external IP address was different 198.20.x.x we had everything set up however, we needed to add the mapping in the host file and the mapping was atually backwards. Plu currently we are still setting up the environment so we have not moved the domain name yet so we set up temperarily which seemed to resolve the issue.

    Thank you and Happy Holidays

    Rich
7 posts, 0 answered