+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Configuration Error

Configuration Error

8 posts, 0 answered
  1. Douglas
    Douglas avatar
    4 posts
    Registered:
    01 Mar 2009
    01 Mar 2009
    Link to this post
    On first installation of community 3.2 on WHS I get a configuration error whenever I try to open or start a project.

    Parser Error Message reads: "Section or group name 'system.web.extensions' is already defined. Updates to this may only occur at the configuration level where it is defined."

    Every section in that group comes with the same error.

    Could this be due to FPSE or Sharepoint extensions that are used for VWD 2008 express?
  2. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    02 Mar 2009
    Link to this post
    Hi Douglas,

    System.Web.Extensions is Microsoft ASP.NET Ajax assembly. If you have this defined in the machine.config file (as this message would seem) you should remove it from your web.config file. However, make sure that when you move to the production server, you have the same machine.config settings there or you will need to re-add this declaration in the web.config before moving to production server.

    I hope you'll find this information helpful. Let us know if there is anything else we can do for you.

    Sincerely yours,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Douglas
    Douglas avatar
    4 posts
    Registered:
    01 Mar 2009
    03 Mar 2009
    Link to this post
    Yeah, thanks Ivan! That did help bring up the sitefinity management module.  However, it then erred on line 104: <add name=ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" / >

    Okay, so when I took that line out, I was able to set-up a new project. ...but the new project then erred out on runtime with an HttpException (0x80004005): The type 'System.Web.UI.ScriptManager" is ambiguous: it could come from assembly 'C:\Program Files\telerik ............ or from C:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extension.dll'

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    03 Mar 2009
    Link to this post
    Hi Douglas,

    It looks like you are referencing the old System.Web.Extensions dll. Check your web.config file and search your application for "System.Web.Extensions". Ensure that the old version of the assemble is not in your bin folder. You could update your project reference and clean your bin directory and rebuild the project.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Douglas
    Douglas avatar
    4 posts
    Registered:
    01 Mar 2009
    03 Mar 2009
    Link to this post
     Thanks Ivan,

    System.Web.Extensions.dll was in the bin directory. The file version was 1.0.61231.0". Is this the old version? Am I suppose to delete that file or replace it (and where would the new version reside.?)

    How would I update the project reference, clean the bin directory, and rebuild the project?

    The current project is completely the product of sitefinity and I have yet to edit it...so it would be no big deal to delete it. But all the projects would seem to have the same build to it and same errors, no?
  6. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    03 Mar 2009
    Link to this post
    Hello Douglas,

    it would appear you don't have ASP.NET Ajax installed (but, not necessarily). There are several reasons you may be getting in all these troubles:

    1. You are running Sitefinity 3.6 built against .NET 2.0 framework, while you have .NET 3.5 framework installed on your machine (if that's so, ASP.NET Ajax is already installed) - if this is the case, download Sitefinity 3.6 built against .NET 3.5 framework and your problems should be fixed

    2. You are running Sitefinity 3.6 build against .NET 2.0 framework, while you have .NET 2.0 framework installed on your machine, but don't have ASP.NET Ajax installed. If this is the case, please go here:
    http://go.microsoft.com/fwlink/?LinkID=77296 and download ASp.NET Ajax 1.0 and install it.

    If none of this helps or you find it confusing (which it is, I admit), please let us know following:
    1. which version of Sitefinity you are using and if 3.6 against which .NET framework (2.0 or 3.5)
    2. which version of .NET framework you are running
    3. do you have ASP.NET Ajax installed and if so which version
    4. which version of IIS you are running
    5. which OS you are running

    I am sure, we'll sort it out then.

    All the best,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  7. Douglas
    Douglas avatar
    4 posts
    Registered:
    01 Mar 2009
    03 Mar 2009
    Link to this post
    Ivan --

    You are a genius, I did download the wrong build. The new build works fine so far. I'm begining to like this product and support, very much.

    Thanks Ivan,

  8. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    03 Mar 2009
    Link to this post
    Hello Douglas,

    I am really glad that we've sorted it out. Do not hesitate to write us if you need any further assistance. We are also very happy to hear that you like the product and our support services.

    Regards,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
8 posts, 0 answered