+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.2 SP1 can't use default.aspx

3.2 SP1 can't use default.aspx

4 posts, 0 answered
  1. Cory Isakson
    Cory Isakson avatar
    5 posts
    Registered:
    08 Aug 2003
    01 Apr 2008
    Link to this post
    I would like my default home page to be default.aspx and to be managed through SiteFinity.  There is a static default.aspx in the root of SF sites.  When I try to create a default.aspx in the admin it renders the static file and I am unable to edit the page.  What can I do to have this a managed page?
  2. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    01 Apr 2008
    Link to this post
    Hmmmm...

    I believe the root "default.aspx" file could be removed...it appears to just be a placeholder page.  I personally didn't need to remove this file though. 

    I tested this quickly and I was able to create a "Default" page in Sitefinity, make it my homepage, and everything worked just fine.

    Once done I was able to type: http://localhost/default.aspx and be directed to the "Default" page that I created via Sitefinity.  The "Default" page you create in Sitefinity likely needs to be set as your homepage however.

    Gabe Sumner
    http://www.goondocks.com/
  3. Cory Isakson
    Cory Isakson avatar
    5 posts
    Registered:
    08 Aug 2003
    01 Apr 2008
    Link to this post
    Gabe,

    I am using the BlankProject package for the 3.2 SP1 release.  Is that what you tested with?

    I was not able to make it work with or without the default.aspx file.
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    07 Apr 2008
    Link to this post
    Hi Cory Isakson,

    You can try the following :

    1. In your project root folder, rename "Default.aspx" to something else, for example "Default1.aspx"
    2. Restart the IIS.
    3. Now you should be able to create a page "default" in the administrative part. You should also be able to manage this page and set it as a home page. We tried this using a Blank Project, SF3.2 SP1.

    Let us know if your problems persist.
     
    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
4 posts, 0 answered