+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.2Sp : fix yourself Administration/Services/Permissions

3.2Sp : fix yourself Administration/Services/Permissions

8 posts, 0 answered
  1. Pierre
    Pierre avatar
    433 posts
    Registered:
    16 Feb 2006
    29 Mar 2008
    Link to this post
    Hi,:
    Fix yourselft the Error for template in Administration>Services>Permissions

    Change in SF/Admin/CmsAdmin/Services.aspx

    /Sitefinity/Admin/CmsAdmin/Services.aspx?perms=perms

    by this

    NavigateUrl="~/Sitefinity/Admin/CmsAdmin/Permissions.aspx"

    bbye

    This error :

    A required control was not found in the template for "Telerik.Security.WebControls.ServicesPermissionSet+Container". The control must be assignable form type "System.Web.UI.ICheckBoxControl" and must have ID "allowNotifications".

    Description : Une exception non gérée s'est produite au moment de l'exécution de la demande Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.

    Détails de l'exception: System.Web.HttpException: A required control was not found in the template for "Telerik.Security.WebControls.ServicesPermissionSet+Container". The control must be assignable form type "System.Web.UI.ICheckBoxControl" and must have ID "allowNotifications".
  2. Pierre
    Pierre avatar
    433 posts
    Registered:
    16 Feb 2006
    29 Mar 2008
    Link to this post
    Sorry Is not that. Wait for official fix
  3. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    31 Mar 2008
    Link to this post
    Hello Pierre,

    This has been fixed in Sitefinity 3.2 SP1, so we'd recommend you upgrade your project.

    Regards,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. Pierre
    Pierre avatar
    433 posts
    Registered:
    16 Feb 2006
    31 Mar 2008
    Link to this post

    Hi,

    I have tested with Emplyproject Standard and dev and same problem. SP1. Fixed?

    Regards

  5. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    31 Mar 2008
    Link to this post
    Hi Pierre,

    Yes, we are sure this has been fixed for the 3.2 SP1 release. Maybe your upgrade was not successful. To verify this, we'll need to know the exact version of your Telerik.Security.dll.
    To check it, please open your project bin folder, right-click Telerik.Security.dll and go to the Properties >Version tab. If the upgrade was successful, the version number should be 3.2.1526.2

    If the .dll is the same version, please describe the steps to reproduce the error.

    Thank you for your cooperation in advance.

    All the best,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Pierre
    Pierre avatar
    433 posts
    Registered:
    16 Feb 2006
    31 Mar 2008
    Link to this post
    Hi,

    EmplyProject dev : 1526.1
    EmplyProject std :  1526.2

    I use EmplyProject dev. lic. 1526.1.  No working Newsletter and this Error when you go to Administration/ Services/Permission and you select permission to set this.

    Regards
  7. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    01 Apr 2008
    Link to this post
    Hi Pierre,

    Is this a project you created with the clean installation of 3.2 SP1 or did you upgrade an old project?
    If it is a new project, created with 3.2 SP1, please send us the whole project as we cannot reproduce the issue.
    If it is a project that you upgraded, please send us the database of the original rpoject, so we can look at it locally.

    As for Newsletters, what exactly do you mean by "No working Newsletter"? Please send us any errors you get, together with the exact steps for reproducing this behavior.

    Thank you for your cooperation in advance.

    Greetings,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. Pierre
    Pierre avatar
    433 posts
    Registered:
    16 Feb 2006
    02 Apr 2008
    Link to this post

    Hi Rebecca,

    I have started with complete new sp1 are now the interface works. It's probably a upgrading problem. You can close this item.
    Thanks for support.

Register for webinar
8 posts, 0 answered