+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.6.1936 Cannot disable blog comments

3.6.1936 Cannot disable blog comments

4 posts, 0 answered
  1. Victor
    Victor avatar
    44 posts
    Registered:
    10 Mar 2009
    26 May 2009
    Link to this post
    I want to disable blog comments and replace them with my own control authenticating to a third party application:

    I set allowComments="False" for all providers in web.config but the "Post a Comment" section still shows.

                    <add name="Blogs" urlRewriteFormat="[Publication_Date]/[Title].aspx" urlDateTimeFormat="yy-MM-dd" urlWhitespaceChar="_" visible="False" defaultMetaField="Title" applicationName="/Blogs" allowVersioning="True" allowComments="False" commentsModeration="true" allowLocalization="False" localizationProviderName="" allowWorkflow="False" securityProviderName="" versioningProviderName="" connectionStringName="GenericContentConnection" type="Telerik.Blogs.Data.DefaultBlogProvider, Telerik.Blogs.Data"/>

    External templates won't work either.
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    27 May 2009
    Link to this post
    Hi Victor,

    allowComments property in the web.config disables the Comments section in the admin side. To disable the "Comments" in the public "Blog Post" control just open it, go to 3rd Step and uncheck "Comments" and "Comments Link" properties.

    Kind regards,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Jim
    Jim avatar
    7 posts
    Registered:
    17 Feb 2009
    08 Jun 2009
    Link to this post
    I have tried disabling the comments under Modules ====> Blogs ====>Blog Settings but the comments link still appears. What am I doing wrong?
  4. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    09 Jun 2009
    Link to this post
    Hi Jim,

    Please, do the following steps:
    1. Edit the page that has Blog Posts control
    2. Edit the Blog Posts control
    3. Click on the "Settings" link in the Basic tab in the Blog Posts control
    4. Remove the tick for Comments options (see the attachment)
    5. Click on the "I'm done" button
    6. Publish the page

    Hope this helps.

    Greetings,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
4 posts, 0 answered