+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / 3.6/7 Image library problem

3.6/7 Image library problem

6 posts, 0 answered
  1. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    03 Nov 2009
    Link to this post
    I have created an image library and succesfully uploaded 16 pictures to the library.  All of the pictures appear fine in the library and I can view and edit their properties.

    (5% of the pictures can be dropped into a content editor control or an image control and display just fine.  However 2 or 3 of the images only appear as a red X.

    I have deleted the images from the library and reuploaded them.  I have tried renaming them.  I even tried registering the ISAPI extensions even though Sitefinity is no longer supposed to use them.  Nothing works.

    I need help on this!
  2. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    03 Nov 2009
    Link to this post
    More information on this...

    You can download the image and click open and the image will open perfectly.  But if you choose "Link to this item" in the image library and then paste the url into a new window you get the big red x again.
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    03 Nov 2009
    Link to this post
    Hello bleutiger,

    Since about 10 or more  images are visible and only 2-4 are broken there should be something to these files or you have made some modifications in the urlRewriteFormat of the provider. Is there a live website where we could try to reproduce this behavior? Have you upgraded your project?

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  4. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    03 Nov 2009
    Link to this post
    Unfortunately we are not ready to upload this to a live server yet.  We are redesigning our site from the ground up with Sitefinity as the core framework...Great Product by the way...

    I have not made any customizations at all to the base sitefinity controls.  But I did do an upgrade from 3.6 to 3.7 via the instructions on the Sitefinity site.  (FYI this is the standard edition not community even though we have not dropped our license key in yet)

    What information can I provide you.  I could zip my entire project and email it to you but you would need to give me instructions on how to get you the DB information you you could see it.
  5. bleutiger
    bleutiger avatar
    153 posts
    Registered:
    23 Oct 2008
    03 Nov 2009
    Link to this post
    Ok so after your last post I decided to open photoshop and resave the images.

    This seemed to fix the issue but I am not sure why.  They should have been standard JPGs.  Is there any reason why embedded meta information could cause an issue with the process.

    Also I recieved the pictures from another dept and did not do my due diligence on the file size they were both about 2mb in size.  Not optimized by a long shot I know.  Could the size of the file have caused the issue?

    Since these are being store in a library in the database I was thinking there may hbe a size limitation imposed by the database which doesn't effect the creation of the thumbnails but does effect the output of the picture.

    I am asking these questions to learn and also to help anyone else who accidently uploads a file that is ginormous.

    Thanks in advance,
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    04 Nov 2009
    Link to this post
    Hi bleutiger,

    The size should not be a problem. Most probably there was something wrong with the image and the data in the header. If someone else was facing the same problem and could share any details for the community, it will be great.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
6 posts, 0 answered