+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Configuration Error

Configuration Error

8 posts, 0 answered
  1. Indian Philosophical Congress
    Indian Philosophical Congress avatar
    19 posts
    Registered:
    09 Apr 2010
    25 Jun 2010
    Link to this post
    Hi !

    I have designed and deployed the following site using Sitefinity Community Edition:
    http://indianphilosophicalcongress.in

    However, I keep getting a configuration error (see attached file) erratically when I try to view the panel options under tab 'aapac 2010'. They are not consistent. Sometimes when I click "Theme>>", it might crop up, sometimes when I click some other panel button.

    This occurs most frequently when I use IE as the browser to view the site.

    Could you help me with this?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Jun 2010
    Link to this post
    Hi Indian Philosophical Congress,

    Could you try increasing the executionTimeout and maxRequestLength of the application. Since the error is sparodic there is something that consumes the memory only on certain requests. Check whether you have some data bound control on the problematic pages that loads big mount of items.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Indian Philosophical Congress
    Indian Philosophical Congress avatar
    19 posts
    Registered:
    09 Apr 2010
    25 Jun 2010
    Link to this post
    Hi !

    I have .NET Framework 1.1 on my machine & as per the below link, the default executionTimeout=90 seconds & maxRequestLength=4096  KB
    http://msdn.microsoft.com/en-us/library/e1f13641.aspx

    Currently, my web.config has the following settings:
    <httpRuntime maxRequestLength="51200"/>
    The executionTimeout is not set (so I assume it will be the default)

    Any suggestions on what I should change it to?

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Jun 2010
    Link to this post
    Hi Indian Philosophical Congress,

    Change maxRequestLength to "2097151" . You could also observe the CPU and RAM peaks of the server if there will be some useful information.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Indian Philosophical Congress
    Indian Philosophical Congress avatar
    19 posts
    Registered:
    09 Apr 2010
    25 Jun 2010
    Link to this post
    Hi !

    It's working ok now. I changed the web.config as per your suggestion & uploaded it to production. But I kept getting the Config error. So, as a whim, I just restarted my local machine & since then  it's been working perfectly! I'm clueless why a restart should have helped since I was using the app from the production server! Should I rest contented or is it a latent bug?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Jun 2010
    Link to this post
    Hi Indian Philosophical Congress,

    Restarting the application releases all resources and flush the server. Actually I have seen the problem you reported only with version of RadControls prior 2008 year where there was a bug.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Indian Philosophical Congress
    Indian Philosophical Congress avatar
    19 posts
    Registered:
    09 Apr 2010
    04 Jul 2010
    Link to this post
    Hi !

    I was stress testing my website (http://indianphilosophicalcongress.in) prior to release & I find the Configuration Error keeps popping up randomly even after changing maxRequestLength to "2097151". It is less frequent but very much there.

    You mention that:
    "Actually I have seen the problem you reported only with version of RadControls prior 2008 year where there was a bug."

    Is it possible that by some chance I have an older version of RadControls installed? How can I check this? I am using Sitefinity Community Edition.

    Thanks.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    04 Jul 2010
    Link to this post
    Hi Indian Philosophical Congress,

    You could check the version of Telerik.Web.UI dll and the actual date release of the dll.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
8 posts, 0 answered