+1-888-365-2779
Try Now
More in this section

Forums / Bugs & Issues / Admin SiteMap Treeview not navigating...

Admin SiteMap Treeview not navigating...

3 posts, 1 answered
  1. Jess Askey
    Jess Askey avatar
    20 posts
    Registered:
    25 Feb 2010
    16 Dec 2010
    Link to this post
    Hello...

    I recently upgraded from 3.7 to 3.7 SP4 (plus moved site to .NET 4.0) and since then, the sitemap treeview doesn't navigate to any pages when clicked. It simply does a postback and then jumps back to the 'All Pages' node and continues to display the recent page list in the right side content area.

    On my computer (Windows 7), this happens in both Firefox 3.6 and IE 8 and on a Mac is doesn't work in FF or Safari.

    Any ideas.... Im sure it is something I have missed in upgrade perhaps?

    thank you....

    jess
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    16 Dec 2010
    Link to this post
    Hi Jess Askey,

    Please check whether you have not missed any step from the upgrade instructions
    and compare again your web.config with this one from the patch.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. Jess Askey
    Jess Askey avatar
    20 posts
    Registered:
    25 Feb 2010
    17 Dec 2010
    Link to this post
    Ahh... those are great instructions... thank you.

    The problem ended up being some missing config buried deep in the web.config in the pages directive...

    <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">

    thanks again.
Register for webinar
3 posts, 1 answered